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Agenda

Field Exercise

Lab Exercise

Break

June 2014

What You Will Learn

Create and edit spatial data while working on a 
sampling design project

Navigate and create point, polyline and polygon 
data using a Garmin GPS device

Transfer spatial data onto and off the GPS device

Create metadata for your GIS data 
June 2014
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Materials

GPS Unit
Exercise

ArcGIS 10.2
R
DNRGPS

C:\Amazing

June 2014

GPS Mapping Field Project

How much asphalt is 
needed for the inner 
trails and the Blue, 
Green & Yellow 
parking lots?
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Some Important Concepts

GIS Data Types and Models

Spatial Reference

Metadata

Sampling Design

June 2014

GIS Data Types - Raster

June 2014
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GIS Data Types - Vector

PolygonsPoints Lines & Polylines
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GIS Data Models

June 2014
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Components of Spatial Reference

Coordinate System

Projection

Datum

Transformations 

June 2014

What’s a Coordinate System?

A reference frame that ID’s a location relative to 
a known reference point

X=1, Y=3

0

Y

X

E=1, N=3, Z=4

0

N

E

Z
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Geographic Coordinate Systems (GCS)

Good for Identifying positions on a globe!  

Bad for distance and area calculations.

No uniform units of 
measure! 

Coordinates must be 
projected to measure 

area and distance.

June 2014

Projected Coordinate Systems (PCS)

A flat 2D surface projected from a 3D globe

Cartesian grid (XYZ) based on a GCS

Distances measured in units of meters and feet

June 2014
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What’s a Map Projection?

The cartographic process that flattens the Earth’s 3D 
surface onto a two-dimension map 

Every flat map misrepresents the surface and distorts
area, shape, distance, direction, bearing & scale

Planar Conic Cylindrical

June 2014

Common Map Projections

June 2014
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Datum – A Reference Point/Surface

Defines the shape 
and Center of the 
Earth

Used to ID unknown 
locations on the 
earth surface

Ellipsoid
June 2014

Common Earth-Centered Datum's

Datum Name Comments

WGS84 World Geodetic System of 1984 The NAVSTAR GPS Datum;
WGS84 spheroid

SGS90 Soviet Geodetic System of 1990 The GLONASS GPS Datum

NAD83 North American Datum of 1983 Up to 2 meter difference from 
WGS84; GRS80 Spheroid

ETRS89 European Terrestrial Reference 
System of 1989

GRS80 Spheroid

June 2014
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What’s your Elevation?

Geoid

Ellipsoid

June 2014

Spatial Reference in ArcMap

WGS_1984_UTM_Zone_43N
WKID: 32643 Authority: EPSG

Projection: Transverse_Mercator
False_Easting: 500000.0
False_Northing: 0.0
Central_Meridian: 75.0
Scale_Factor: 0.9996
Latitude_Of_Origin: 0.0
Linear Unit: Meter (1.0)

Geographic Coordinate System: GCS_WGS_1984
Angular Unit: Degree (0.0174532925199433)
Prime Meridian: Greenwich (0.0)
Datum: D_WGS_1984

Spheroid: WGS_1984
Semimajor Axis: 6378137.0
Semiminor Axis: 6356752.314245179
Inverse Flattening: 298.257223563

Is a Coordinate System, 
Projection in some cases, and a 
Datum.

If not set, the data frame takes 
on the spatial reference of the 
first data set.

June 2014
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Spatial Reference in ArcMap

• If the added data has a 
different GCS (i.e., datum), a 
datum transformation is 
required (Warning)

• You can either set the 
transformation in the warning 
dialog or data frame 
properties

June 2014

Transformations

Many to chose from, but how 
do you decide?

June 2014
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Defining a Spatial Reference

If unknown… you need to figure out what the file is 
actually stored in first!

• Check the metadata

• Add it to a map with a known projection

• Look at the numbers

• Contact the source and ASK

June 2014

What you really need to know

Ensure all layers have spatial reference defined

Be sure the correct spatial reference is defined

Ensure all layers have same spatial reference when 
performing spatial analysis

June 2014
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Online Resources

Projection Basics: What the GIS professional needs to know  
(Article ID 23025, web help) 

How to Select the correct datum transformation 
(Article ID 21327, web help)

NOAA online Training:
http://www.csc.noaa.gov/digitalcoast/training/datums

June 2014

Metadata

Don’t forget it!

At very least include…

Contact, Purpose & Quality

Else……

June 2014
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Next Topic - Sampling Design

June 2014

Sampling Design - Why Sample?

A census is impractical or impossible

Statistical models assume a random distribution

Reduce BIAS and increase PRECISION in estimates

June 2014
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Sampling Designs

Systematic

Simple Random

GRTS BAS

Spatially Balanced

Random
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Create Sampling Design’s Using ArcGIS and R 

 
 
 
Session Objectives - At the conclusion of this session you will be able to: 
 
 
 Use ArcGIS and R software to create sampling designs for studying wildlife 

populations and their habitats. 
 

 Create and edit vector data from a shapefile and geodatabase. 
 

 Use the cut polygon tool and dissolve geoprocessing tool. 
 

 Use DNRGPS software to transfer data onto a Garmin GPS device. 
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Materials created by: Eric Kelchlin (May 2014) 

Revision:  
Software: ArcGIS 10.2.2, R 3.10, DNRGPS 6.1.05 for ArcMap 10.2 

R-Packages (zip files): SDraw_1.01, sp_1.0-15, spsurvey_2.6, spsurveyGUI_1.0, 

RGtk2_2.20.27,  

Directory Path:  D:\Amazing 

GDB: NCTC.gdb (students create) 
MXD: Sampling_Design.mxd (students create) 
Imagery: Aerial_2009.sid (UTM 18N, NAD83) 
 
Software Links: 
Garmin USB Driver  http://www8.garmin.com/support/download_details.jsp?id=591  

DNRGPS 6.1.05  http://www.dnr.state.mn.us/mis/gis/DNRGPS/DNRGPS.html  

Garmin Web Updater*  http://www8.garmin.com/products/webupdater/howtoinstall.jsp  
 
R  http://www.r-project.org/  
 
*The Garmin Web Updater software updates the OS and firmware on your GPS unit.  
This software is not needed for this exercise, but is very necessary to keep current with 
updates.  
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SECTION 1 – Creating Sampling Points 
 
You will be asked to generate sampling points, plots or transects across a study area at 
some time in your career.  With the help of ArcGIS and R statistical software you can 
easily create a sampling design for a wide array of inventory and monitoring 
applications.  Best yet, you can then upload this data into your GPS unit and laydown 
the sampling design in the field. 
 
All data are located in the D:\Amazing folder unless otherwise stated. 

 
TASK 1 - Create a New GIS Project 

 
1. Launch ArcCatalog to create a new file geodatabase. 

 
• Right-click on the Amazing folder and select New > File Geodatabase.   

 
• Name the geodatabase NCTC. 

 
2. Right-click on the NCTC.gdb and create a new Feature Dataset (FDS) and name 

it Sampling.  Next, assign the coordinate system. 
 

• Browse down into the Projected Coordinate System folder and select NAD 
1983 UTM Zone 18N. 
 

• Click the Add to Favorites button to bring it to the top for later use. 
 

 
 

• Click Next twice and Finish to accept the default tolerances. 
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3. Right-click on the Sampling FDS and create a new polygon Feature Class (FC).  

Name it Sampling_Area. 
 

• Click next twice to get to the attribute table.  Create a new text field and 
name it Habitat_Type.  Give it a length of 20 characters. 
 

 
 

• Click finish when done.  You should now have a file geodatabase that 
looks like this one below: 

 

 
 
 

4. Close ArcCatalog and launch ArcMap. 
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5. Select a new Blank Map document (MXD) and assign the NCTC.gdb as our 

default geodatabase from the Getting Started dialog.   
 

 
 

6. Open ArcCatalog from the sidebar and create a new folder connection  to 
D:\Amazing to speed-up our browsing to the project folder. 
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7. Add data to our blank Data View. 

 
• Add the Aerial_2009.sid file from the Imagery folder by just dragging and 

dropping the file onto the blank Data View. 
 

• Add the Sampling_Area FC from the NCTC geodatabase. 
 

8. Save   the map document and name it Sampling_Design.mxd. 
 

 
TASK 2 – Define a Study Area 

 
1. Start an editing session and digitize a study area. 

 
• Click on the Sampling_Area symbol in the Table of Contents (TOC) and 

change the symbology to no fill color, outline width of 2 and pick a bright 
color. 
 

• From the Editor Toolbar, select Edit > Start Editing. 
 

• From the Create Feature dialog, select the Sampling_Area FC and 
Polygon in the Construction Tools dialog.   

 

 
 

• Zoom into the center of the image by using the mouse scroll wheel.  Scroll 
forward to zoom in, backward to zoom out.  You can also push down on 
the scroll wheel to grab and realign the image as you digitize. 
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• Digitize a similar polygon as shown below.   Double-click on the last 

vertices to finish the polygon. 
 

• Save your edits and stop editing (Edit > Save Edits and Stop Editing).  
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TASK 3 – Create Simple Random Samples 

 
1. Randomly distribute 100 points using the Random Tool in ArcToolbox. 

 
• Open ArcToolbox on the sidebar and browse down to the Create Random 

Points tool (Data Management Tools  Feature Class).  Double-click on 
the tool to launch it.  Note: You can easily use the Search tool on the 
sidebar to find the tool as well. 
 

• Populate the dialog as shown below and run the tool.  Make sure to save 
the new Rand_Samples FC within the Sampling FDS. 
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2. Notice how the points can be clumped, even on top of each other.  This is a 

known drawback with using the simple random sampling approach.  A work 
around is to change the minimum allowed distance to something other than 0. 
 

• Run the Create Random Points tool again, but this time change the 
minimum allowed distance to 3 meters.  Name the new FC as 
Rand3_Samples. 

 
• Did this improve the clumping issue? 

 
 

TASK 4 – Create Stratified Random Samples 
 
1. Randomly distribute 100 points across a user defined strata.  We’ll use habitat 

type as the strata for this example.   
 

• Start an editing session and use the cut polygon tool  to create Forest 
habitat polygons within our study area polygon.  The cut tool will make 
polygons that have no gaps and do not overlap.  The instructor will show 
you how to use the cut polygon tool. 
 

• Attribute each polygon as either Forest or Grassland. 
 

• Save edits and stop editing. 
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2. Next, use the Dissolve tool in the Geoprocessing toolset on the main menu to 

merge polygons with the same habitat type.  This will combine records with the 
same habitat type in the attribute table, but it will retain unique geometries.  This 
is called a multipart feature.  

 
• Rename the FC as shown below.   

 

 
 

 
3. Run the Create Random Points tool on your new FC and create 100 sample 

points among the habitat types. 
 

• Would the results be the same if we did not use the Dissolve tool before 
we created the random points? 
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Challenge Exercise:  Notice how the new random points are identified by a number 1 
or 2 in the attribute table.  It would be nice to have the habitat type names to the 
attribute table instead of some erroneous numbers.  What’s a quick way to accomplish 
this? 
 
SECTION 2 – Sampling Design Using the SDraw Package in R 
 
SDraw, developed by Trent McDonald of West Inc., allows you to create systematic 
samples with ease.  But more importantly, SDraw also gives you capability to create 
spatially balanced sampling designs; this includes BAS (Balanced Acceptance 
Sampling) and GRTS (Generalized Random Tessellation Stratified) sampling designs.   
You have a PDF document about BAS in your documents folder.  To learn more about 
GRTS click 
here: http://science.nature.nps.gov/im/datamgmt/statistics/r/advanced/grts.cfm 
 
 
TASK 1 – Create a Sampling Plot (Shapefile Format) 
 

1. R does not work with geodatabases, so we need to create a sampling frame 
that’s in a shapefile format.  Instead of creating another irregular polygon for this 
example, let’s go ahead and create a polygon with specific geometry like a 
square sampling plot, grid or quadrat. 
 

• Open ArcCatalog on the sidebar.  Right-click on the Amazing folder and 
select New > Shapefile.  
 

• Name it Sampling_Plot and assign the appropriate coordinate system. 
 

 
 

 
• Remove all your layers in the TOC except for the imagery and 

Sampling_Plot.    
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2. We’re going to make a 200 meter square plot.   

 

• Start an editing session and zoom into  a different section of the 
campus.   
 

• Select Sampling_Plot in the Create Features dialog to initiate editing, and 
then select the Rectangle Construction Tool. 
 

• Left-mouse click once to get the plot started.  Drag the mouse down and 
right-mouse click to view your options. 
 

 
 

• Select Length.  Type in 200 and hit the enter key. 
  

• Right-click one more time, and select Width.  Type in 200 and hit the enter 
key.  You should now have a 200 meter square plot. 
 

• Stop Editing and save your edits.  
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TASK 2 – Working with R 
 

1. Launch R, change the working directory and load the SDraw Package. 
 

• On the main menu select File > Change dir and browse to the 
D:\Amazing folder.  We can now access our new shapefile and the 
outputs will be saved in the working folder. 
 

• Select Packages > Load package.  Select SDraw from the list of 
packages and select OK.  You should now see S-Draw on the main menu.  
This is unique to R packages, so don’t expect a main menu item to appear 
with other packages. 

 

 
 

 
2. Create a systematic grid of points. 

 
• Select S-Draw > Equi-probable Designs.  The GUI may be hidden 

behind other windows, so may have to go fish for it. 
 

• Change the Sample type to SS–Simple Systematic Sampling and 
populate the rest of the fields as shown below. 
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• Click Run to create the dataset, then Write Shapefile to create the 
shapefile.  Leave the GUI open. 
 

 
3. Create BAS and GRTS sample of points. 

 
• Change the Sample type to BAS.  

 
• Change the Output object to BAS_Samples.  Keep the rest of the fields 

the same. 
 

• Run the tool and Write the Shapefile. 
 

• Change the Sample type to GRTS and repeat the process.  Name the file 
GRTS_Samples. 

 
• Click Done and exit out of R. 

 
 
  

Sampling Design                                                                                      14 
 



Directorate Fellows Program Training                                                                                   2014 
U.S. Fish and Wildlife Service                              National Conservation Training Center 

 
TASK 4 – Import the Shapefiles into the Geodatabase and View the Results 
 
R does not create projected shapefiles.  However, we know the spatial reference is 
NAD83 UTM18 because we assigned it to our Sample_Plot shapefile.   A quick way to 
provide a spatial reference for these files is to import them into our Sampling FDS.  Any 
layer imported into a FDS will be automatically assigned the spatial reference of the 
FDS. 
 

1. Import the shapefiles and convert them into feature classes. 
 

• Open ArcCatalog on the sidebar and right-click on the Sampling FDS in 
the NCTC geodatabase. 

 
• Select Import > Feature Class (multiple)… 

 
• Add the three shapefiles and click OK. 

 

 
 
 

• View your sampling points.  How do the distributions look?   
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SECTION 3 – Uploading the Data into the Garmin Map76CSx 
 
In this section you will be using DNRGPS to upload the Sampling_Plot shapefile and 
the BAS_Samples FC you just created.   
 

 
TASK 1 – Delete GPS Data and DNRGPS Setup 
 

1. Delete all the data on your GPS unit first before you upload any new data.   
 

• Turn on your GPS unit and go to the Altimeter Page from the Main Menu. 
 

• Select the Menu button once to bring-up the page specific menu. 
 

• Select Reset on the list, then scroll down to Select All, then scroll down 
and hit Apply.  This will remove all waypoints and tracks in one fell-swoop. 

 
2. Attach you’re Garmin unit to the computer via the USB cable. 

 
3. Launch DNRGPS from the desktop.  

 
4. Change DNRGPS Default Settings. 

 
• Set your projection to NAD83 UTM18N (File > Set Projections). 
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• Set your waypoint properties so that comments, symbol and altitude are 

the only optional fields shown (Waypoint > Waypoint Properties).  
Mandatory fields are gray. 

 

 
• Set your track properties so that comments and altitude are the only 

optional fields shown (Tracks > Track Properties). 
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TASK 2 – Uploading Shapefiles 

 
1. Load the shapefile first by Selecting File > Load From > File from the main 

menu. 
 

• Browse to the Amazing folder, select Sampling_Plot and click OPEN.  If 
you don’t see the file, change the file type to ESRI Shapefile 2D. 
 

• Click OK to accept Id as the TIDENT field.  You screen should look similar 
to the one below. 

 

 
 
 

2. Next, select Track on the main menu and click Upload. 
 

• Select Named Tracks and OK.  You could go either way, but it would be 
better to have the tracks saved separately for easier access. 
 

 
 

3. Go to the Map Page on the GPS unit to view your data.  This is always a good 
idea before you head-out into the field.  Make sure your data is on the GPS unit, 
and in a way that you expected it to be.  Garmin loves to connect uploaded 
polygons because it treats lines and polygons as tracks. 
 

• If you don’t see your track on the Map Page, then tap Menu Menu twice 
and select to the Tracks icon. Scroll down the saved tracks section and 
select your track.  Hit the Enter Key and select the Map button at the 
bottom right of the dialog.  You’ll be sent the location of the track on the 
Maps Page. 
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TASK 3 – Uploading Feature Classes 

 
1. Upload the BAS_Samples point FC.  The process is more involved than 

uploading a shapefile.  To upload a FC you first have to connect to the database. 
 

• Select File > Load From > Database.  Click Add. 
 

• Change the fields to what is shown below.  Test the connection and click 
OK. 

 

 
 
 

• Select the BAS_Samples FC and click OK.   
 

 
 
 

• Finally, select the SiteID for the IDENT values and click OK. 
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• Select Waypoint > Upload to copy the points over to the GPS unit. 
 

• Look at the map page on the GPS unit and see if all the points made it 
over. 
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APPENDIX – How to Create Sampling Transects  
 
In this last section were going to create 100 meter long transects and generate 
systematic points along these transects.  This sampling design is often used for bird 
point count transects and point-line-intercept vegetation surveys. 

  
1. Create a new line feature class and name it Transect100.   

 
2. Change the symbology of the line to better see the line as it’s digitized on the 

on the imagery.  I chose the Highway Ramp symbol.   
 

3. Start an editing session and create the 100 meter long transect.   
 

 
 

• Left-mouse click once on the image.  Drag the mouse down and right-
mouse click.  Select Length in the pop-up menu.  Type 100 and hit Enter 
on the keyboard. 

 
• Drag the mouse in the direction you want the transect follow and left-

mouse click to create the second point.    
 

• Right-click and select the Finish Sketch  button on the Feature 
Construction Toolbar, and you’re done. 
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4. Make two more 100 meter transects that run parallel to the first using the Editor 

Toolbar.  
 
• Click on the Editor button on the Editor Toolbar and select Copy Parallel. 

 
• Use a 20 meter distance shown below and click OK.  You should now 

have 3 transects, each one paralleling the other at a 20 meter distance. 
 

 
 
 

• Stop editing and save edits. 
 
 

5. Finally, we’re going to add sampling points at regular intervals along each 
transect. 
 
• First, create new point feature class and name it Transect_Points.  

Create a short integer field in the attribute table and title it Point_ID.  We’ll 
use this field for labeling the points later on. 
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• Start a new editing session. 

 

• Use the Editor Tool arrow  to select one of the transects.   
 

• Click on the Editor button and select Construct Points.  
 

 
 

• Create a point every 10 meters, starting from the beginning of the 
transect.  See the example below.  Make sure you’re using the right 
Template. 
 

 
 

• Repeat this process for the other two transects. 
 

6. Label the Transect_Points layer using data from Point_ID field.  But, first create 
the data! 

 
• Open the Transect_Points Attribute table and use the Field Calculator to 

create a sequential list of numbers in the Point_ID field.     
 

• Right-click on the Transect_Points layer and select Label Features.   
 

• Change the field to Point_ID in the layer Properties if needed. 
 

 

Sampling Design                                                                                      23 
 



Directorate Fellows Program Training                                                                                   2014 
U.S. Fish and Wildlife Service                              National Conservation Training Center 

 
 

 
 

7. Stop editing, save edits, save  the map document (MXD) and close ArcMap. 
 
 
 
Challenge Exercise:  Create another transect and add points to the line at RANDOM 
distances.  What tool(s) did you use________________________________________? 
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Team GPS Mapping Project 
 
 
 
Session Objectives - At the conclusion of this session you will be able to: 
 

 
 Conduct a multi-user GPS project 
 
 Import GPS field data into a geodatabase 

 
 Edit line and polygon data in ArcMap 10.2 using advanced editing tools 
 
 Calculate length and area using the Calculate Geometry function 

 
 Create holes in polygons using the Erase Tool 

 
 Quickly create metadata  
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Materials created by:  Eric Kelchlin, August 2011 

Revision: May 2014 

Software: ArcGIS 10.2.2, DNRGPS 6.1.05 for ArcMap 10.2, 

Directory Path:   D:\Amazing\Field_Project 

Documents: Infrastructure_Project_Summary.docx 

GDB: NCTC_2.gdb  
MXD: GPS_Mapping.mxd  
Imagery: Aerial_2009.sid (UTM 18N, NAD83) 
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GPS Project Summary 

Title:  NCTC Infrastructure GPS Mapping Project 

Requested by: Joe Maintenance (joe_maintenance@fws.gov) 

Problem Statement: 
NCTC has a network of paved trails and parking lots.  Facilities Operations would like to 
map the paved trails to determine how much paving material would be needed for a 
complete replacement in the near future.  They would also like to determine how much 
asphalt would be needed to replace the large parking lots.  A team approach will be 
necessary to speed-up the data collection process due to time constraints.  The trail 
segments should be merged into one layer with no dangles and gaps.  The parking lot 
will need to have the islands completely removed from the polygon to not overestimate 
the asphalt area.  Finally, Joe’s supervisor requires that metadata be completed for all 
GIS layers due to high employee turnover. 
 
Objectives & Methodology:  

1. In teams of 2, collect the polyline or polygon features using a Garmin 
Map76CSx.  Use a 2 second logging rate. 

2. Download the GPS data using DNRGPS from both GPS units onto one 
computer and save the data as a line or polygon feature class in the NAD83 
UTM18 projection. 

3. Using the Editor Toolbar and Advanced Editing Tools, remove line dangles and 
gaps and then merge the trail segments into one layer.   

4. Multiply by a trail length of 1.2 meters in width to calculate the area in square 
meters. 

5. Remove the islands from the parking lot polygon using the Erase Tool. 
6. Add an Area (square meters) field in the Parking Lot attribute table and use the 

Field Calculator to find out how much materials are need to pave the parking 
lots to a 10 inch depth (0.254 meters). 

7. Copy and paste this GPS project summary into the Description field of the 
metadata. 

 
Existing Data:   

• GPS_Mapping.mxd and imagery 
 
Deliverables: 

1. To answer the question: how much paving material is needed for the trail and 
parking lot (square meters). 

2. A “clean” trail and parking lot feature class with length and area calculations in 
the attribute tables. 

3. Metadata with the GPS project summary in the description field.  

GPS Mapping Project                                                                                      3 



Directorate Fellowship Program Training                                                                                   2014 
U.S. Fish and Wildlife Service                              National Conservation Training Center 

 
Items to Keep in Mind 
 

1. This exercise is purposely designed to push you’re GIS and GPS skills into 
uncharted territory…so don’t be shy to ask the instructor or team member for 
help. 
 

2. This is a team project, so work together to collect the field data.  Divide up the 
work load, but smartly.  
 

3. You have to decide where to start and stop the trail or perimeter of the parking 
lot.  You can’t just turn the GPS unit on and walk….the result will be a 
connected spider web of overlapping useless data.   Map in segments and save 
results after each segment. 
 

4. When creating polygons (i.e., area features) in the field, you don’t want to start 
and stop in the same location.  Find a starting point at the end or beginning of a 
straight section.  End the polygon well before the starting point and the polygon 
will snap shut.  This will save you time and give you nice strait lines where you 
want them. 

 
 

  

GPS Mapping Project                                                                                      4 



Directorate Fellowship Program Training                                                                                   2014 
U.S. Fish and Wildlife Service                              National Conservation Training Center 

 
SECTION 1 - Downloading Field Data Using DNRGPS  
 
All data are located in the Amazing\Field_Project folder.   
 

1. Launch ArcMap and open the GPS_Mapping map document. 
 

2. Turn on the GPS unit and attach your GPS unit to the computer using the USB 
cable.  Be careful with the earflap on the back of the GPS unit….it will come off!   
 

3. Launch DNRGPS.  The model of the GPS unit will be shown just below the 
main menu after a few seconds indicating the connection has been made.  
 

4. Make sure you have the proper projection set (File>Set Projection). 
 

5. Download the waypoints and tracks (e.g., lines and polygons) at one fell swoop 
by selecting GPS > Download All.  You can do waypoints and tracks 
individually under each respective button, but this method is quicker. 

 

 
 
 

6. Saving Waypoints as a Feature Class- select the Waypoints tab just above 
the table to view all your waypoints.   
 
• Select File > Save To > ArcMap > Database  

 
• Click Add to add a connection to the geodatabase.  Browse to the 

NCTC_2.gdb.  Your dialog should look like the one below. 
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• Test your connection and click OK. 
 
• Save the waypoints as Points_”your initials”.  Click OK. 

 

 
 
 

• Your data should show-up in the TOC in ArcMap. 
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7. Saving lines or polygons as Feature Classes - click on the Tracks tab just 

above the table to view your tracks. 
 
• Select only your named tracks with the click and Shift Key technique. 

 
• Save the files as feature classes as shown in step 6. 
 
• Name the tracks Trails_”your initials”, Parking_”your initials” or 

”islands_”your initials” depending on your project.  Save your parking 
lots and islands as separate polygon feature classes. 
 
 
 

Notes on Active and Named Tracks:  the active tracklog is everything that you saved 
or not saved.  It’s a record of everything you collect once you turn on the tracks from the 
tracks page or click enter on the area calculation page.  If you saved a track, then the 
active tracklog has a duplicate.  So, if you download all your tracks and save them 
without regard of the type of track, then you will have duplicates.  Be careful! 
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SECTION 2 – Trail Team Project 

 
This section illustrates some common editing tasks in ArcMap that are often utilized 
to clean-up GPS line and polygon data.  Your objective is to connect all the line 
segments together, remove dangles and gaps.   You can also adjust any poor data 
locations using the background imagery as a reference.  You might only need to 
perform a couple tasks. 

 
 
TASK 1: Set the Stage 
 

1. Right-click in the “gray area” on the main toolbar in ArcMap and select the 
Snapping and Advanced Editing Toolbars.   Move the toolbars to a desired 
location. 
 

 
 

2. Click on the Snapping drop-down arrow and make sure Use Snapping is 
checked.   

 
• Make sure all 4 snapping buttons on the toolbar (Point, End, Vertex and 

Edge) are depressed. 
 

• On the Editor Toolbar, select the Snapping > Options and set the 
snapping tolerances to 10.  

 
 
TASK 2: Connect Broken Lines 
 

1. Start an editing session by selecting the drop-down arrow on the Editor 
Toolbar and select Start Editing. 

 

2. Click on the Edit Tool  on the Editor Toolbar.  
 

3. Zoom into  the area you will be working in.  
 

4. Using the Edit Tool , double click on the line that you want to edit to show 
its vertices (green boxes). 
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5. Place your mouse over the last vertex until it becomes a box surrounded by 

arrows.  Left click and drag the vertex to the desired location on the other line. 
Notice how the vertex “snapped” to the edge of the other trail. 

 
6. Click on the Finish Sketch icon on the floating Edit Vertices toolbar or 

anywhere on the map to accept your changes.  
 

 
 
 

7. If you make a mistake, use the undo  button on the Standard toolbar. 
 

8. To insert a vertex, click on the Insert Vertex  tool on the Edit Verticies 
toolbar. 
 

9. To delete a vertex, click on the Delete Vertex  tool on the Edit Verticies 
toolbar. 
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TASK 3: Trim lines 

 

1. Zoom in  to the area you will be working in. 
 

2. Use the Edit tool  to click once on the line which will be used to trim the 
desired line.  We will trim the red line where it crosses the selected (blue) line. 

 

3. Click on the Trim tool  on the Advanced Editing toolbar. 
 
 
4. Now, click on the red trail line above the blue selected trail to remove the 

overshoot.  
 

 
 
 
TASK 4: Split lines 
 

This is a useful tool when you have to a lot of vertices to delete and you don’t want to 
waste your time deleting each one separately.  The split tool cuts the line so you can 
delete entire line segments. 

 

1. Zoom in  to the area you will be working in.  Highlight the trail to split with 

the Edit tool . 
 

2. Click on the Split Tool  on the Editor toolbar. 
 
 
3. Click on the line where you want the split to occur.  Select the line segment you 

want to delete and press the Delete Key. 
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TASK 5 - Calculate Trail Length and Area  
 

1. Merge all the trail segments into one multi-part polyline after you’re done with 
the line edits. 
 
• Right-click on the Trails layer in the TOC to open the attribute table.  

Select all the trail segments while still in edit mode.   
 

• Click Merge in the Editor Toolbar. (Note: you can also use Dissolve in the 
Geoprocessing Tools to merge the lines into one multi-part line and create 
a new FC in one step.) 
 

• Save edits and stop editing. 
 

 
 

2. What’s the total length of the Trail in meters____________? 
 

3. To calculate area we need to add a new field first then run the field calculator. 
 

• From the Table Options drop-down menu   in the attribute table view, 
select Add Field.  
  

• Name the field Area.  Change the type to Double and click OK.   
 

• What’s a double anyway?  A double shot of espresso?  
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• To calculate area in square meters, simply right-click on the Area field and 
create the following expression and click OK.  We’re assuming that the 
average width of the trail is 1.2 meters. Don’t mind the warning 
message…you know what you’re doing.   
 

  
 
 
 

4. What’s the total area in square meters___________?   
 

5. What if we wanted to know how much asphalt we need to repave the trails to a 
depth of 10 inches (0.254 meters), how much asphalt would we need 
then________________________? 
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SECTION 3 – Parking Lot Team Project  
 
I hope you listened to your instructor and saved each island and parking lot as a 
separate track and named it accordingly.  Spending a little time in the field to annotate 
your tracks means less time in the office managing the data.  
 
 
TASK 1: Clean-up the Data if Necessary 
 

1. Start an editing session and clean-up any vertices that seem out of place.  
 

• Start an editing session by selecting the drop-down arrow on the Editor 
Toolbar and select Start Editing. 

 

• Click on the Edit Tool  on the Editor Toolbar.  
 

• Zoom into  the area you will be working in.  Use can use the scroll 
wheel on your mouse to do this as well.  Try it! 

 

• Using the Edit Tool , double click on the line that you want to edit to 
show its vertices (green boxes). 

 
 

 
 

• Place your mouse over the vertex until it becomes a box surrounded by 
arrows.  Left click and drag the vertex to the desired location.   
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• Click on the Finish Sketch icon on the floating Edit Vertices toolbar or 

anywhere on the map to accept your changes.  
 

 
 

• If you make a mistake, use the undo  button on the Standard toolbar. 
 

• To insert a vertex, click on the Insert Vertex  tool on the Edit Verticies 
toolbar. 

 

• To delete a vertex, click on the Delete Vertex  tool on the Edit Verticies 
toolbar. 

 
 

2. If you have polygons that are overlapping or bordering and should be one, here 
are the steps to make it all better. 

 
• Select both polygons using the editor arrow and the Shift Key. 
 
• Click Merge from the Editor Toolbar and click OK. 
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TASK 2:  Erase the Islands 
 
Erase the islands?  Has the man lost it?  Perhaps, but what we’re referring to here is a 
tool called Erase that removes inner overlapping polygons and makes donut holes in 
the larger main polygon.  The result is a clean polygon ripe for area calculation. 

 
1. Next, use the Erase Tool to make donut holes in your Parking Lot layer.   

 
• Open ArcToolbox on the side bar and browse to Analyst Tools > Overlay 

to find the Erase tool. 
 

• Your Input feature should be the Parking lots.  The Erase feature will be 
the islands.   

 
• Save the final results as a feature class in the NCTC_2 geodatabase.  

Name the layer Parking_Lots_Final 
 

 
TASK 3:  Calculate How Much Material is Needed 
 
Given that the new pavement will be at a depth of 10 inches (0.254 meters), how much 
asphalt will be needed to repave the parking lots? 

 
 

1. We first need to add a new field first then run the field calculator. 
 

• Right-click on the Parking_Lots_Final laye in the TOC to open the attribute 
table.   
 

• From the Table Options drop-down menu   in the attribute table view, 
select Add Field.  
  

• Name the field Asphalt.  Change the type to Double and click OK.   
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• To calculate area in square meters, simply right-click on the Asphalt field 

and create the following expression and click OK.   Don’t mind the warning 
message…just go for it! 
 

 
 
 
 

2. How much asphalt would we need to repave the parking lots_________?  
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SECTION 5 - Add GPS Project Summary to the Metadata 
 
This is a really quick way to add detailed metadata to your GIS layer.  Most of us simply 
do not have the time to sit down and fill-out all the mandatory 11 sections of metadata.  
So, for practical purposes, l highly recommend that you add the GPS project summary 
to the description field.   The GPS project summary contains plenty of information for 
someone else to evaluate the data quality, and that is essentially the main reason for 
metadata. 
 

1. Launch ArcCatalog  from the desktop.  
 

2. To add metadata, simply highlight your Trails or Parking_Lots_Final layer, 

select the Description tab and select the Edit tool  in the Items 
Description window.    

 
3. Click Item Descriptions in the Overview section and scroll down to 

Descriptions. 
 

4. Open Windows Explorer and copy the text from the 
Infrastructure_Project_Summary.docx file in the Field_Project folder and 
paste in the Items Descriptions field. 

 
5. Click Save.  That’s it!  As long as you have a GPS project summary you can 

create quick and easy metadata. 
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