Exercise 4 — Editing and Data Management in ArcGIS Pro

As with ArcGIS Desktop, ArcGIS Pro allows you to create and modify your geographic data. Editing in
ArcGIS Pro is more streamlined, and intuitive than it is in ArcGIS Desktop. The ArcGIS Pro contextual tabs
using Microsoft ribbon technology takes some of the guess work out of your editing workflows. These
tabs contain many of the common editing tools from ArcMap in one ribbon rather than multiple editing
toolbars.

ArcGIS Pro also provides contextual menus that can be used while editing similar to the workflows you
have used in ArcGIS Desktop. In this exercise you are going to explore the editing environment in ArcGIS
Pro. You will use ArcGIS Pro to create and modify features and attributes, modify a geodatabase table
schema and create attribute behavior properties in a geodatabase.

Topics covered:

e ArcGIS Pro editing environment
e Editing Features

e Snapping

e C(Creating a new feature class

e Creating Domains and Subtypes
e Editing Attributes

e Creating and modifying features

Exercise 2A: Designing a schema

In ArcGIS Pro, you can add, fields to a table, create new feature classes, domains, and use subtypes to
categorize your data. In ArcGIS Pro, environments called Designers allow you to perform these tasks.
The concepts of schema editing are the same as ArcMap, only the methods you will use have changes.
Subtypes are still a feature class property, and domains are still a geodatabase property, but they are
created in a different locations in ArcGIS Pro.
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Step 1: Begin the p

roject

In this exercise, you are going to manage the data necessary to create a new fence boundary.
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Open ArcGIS Pro
Create a new, blank project named Exercise 4

Save the project in location: C:\Esri\ArcGIS Pro\Projects
On the Analysis tab, click Tools to open the Geoprocessing tab
In the search box, search for the term “Copy”

6. Click the Copy tool to copy the Exercisel () geodatabase. Set the Parameters:

You will be importing an MXD that uses this output workspace so make certain the name and output

folder are correct.

Input Data: C:\Esri\ArcGIS Pro\Data\Exercisel.gdb
Output Data Element: C:\Esri\ArcGIS Pro\Outputs Exercise4A.gdb
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When the Copy finishes close the Geoprocessing Pane.

Open the Project Pane. Right click Folders, and then click Add Folder Connection.
In the Add Folder Connection, browse to C:\Esri and select the ArcGIS Pro folder.

Click Select to add the folder to your project.
In the Project Pane, expand Folders > ArcGIS Pro > Outputs
Your new Exercise4A geodatabase should be present in this folder.

Right click on the Exercise4A geodatabase and then select + Add to Project
In the Databases tab of the Project Pane, you should now see the Exercise4A geodatabase.
On the ArcGIS Pro Insert tab, click Import Map, then browse to C:\Esri\ArcGIS Pro\Maps

Select Exercise4A.mxd, and then click Select.

Step 2: Creating a Feature Class
Now that you have imported the existing map into ArcGIS Pro, you will create a new feature class and
then modify its schema. Later you will add some features and update attributes. The main task you will
be performing is to add a new fence to the area. Before creating feature, you will create the feature

class.

1.

On the Analysis tab, click the Tools icon to open the Geoprocessing

Pane.

Search for Create Feature Class tool.

Click the Create Feature Class tool and create a new feature class

using the following parameters:

e Feature Class Location: C:\Esri\ArcGIS Pro\Outputs\Exercise4A.gdb

e Feature Class Name: TempFences

e Geometry Type: Polyline

e Template Feature Class: ExistingFences

e Coordinate System: Projected > World > WGS 1984 Web Mercator
(auxiliary sphere)
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The new feature class has been added to the geodatabase and to the map as a new layer. The new layer
is currently empty but contains the attributes from the fence layer. Next, you are going to modify the
schema to remove unnecessary fields.




4. Open the Field Designer for the TempFences layer (from the Project pane, right click the
TempFences feature class in the Exercise4A.gdb, then click Design > Fields.
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5. Inthe Fields: TempFences panel, select the Notes, Data_Source, FENCE, and CODE fields.

6. Click the Delete button on the Fields tab.

7. The fields are now marked for deletion but they are not actually removed from the table until
you Save the Map Document.
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Save

8. On the Fields tab, click the Save button.
9. On the Fields tab, click New Field to add a field named FENCE_MATERIAL as a short integer.

FENCE_MATERIAL Short J

10. Add another Field named TYPE as a string 100 characters in Length.

TYPE Text F 100

11. Finally, add one more field named DESCRIPTION as a string 100 characters in length.

DESCRIPTION Text 7] 100

12. On the Fields tab, click Save to add the new fields to the table. Close the Fields: TempFences
tab.

You have now successfully created a feature class, deleted and added additional fields to the table. Your

table should look
similar to 4 Field Name Alias Data Type Domain Default Length the graphic
below: SR SR — .

FENCE FENCE Text 50

NOTES NOTES Text 240

DATA_SOURCE DATA_SOURCE Text 5

SOURCE SOURCE Text 20

CODE CODE Text 20

DESCRIPTION Text 100




Step 3: Applying a Domain to a new Feature Class

You want to create and apply an attribute domain to the TempFences feature class to aid in data entry.
You will create the domain, then apply it to the feature class. Domains are the property of a
Geodatabase so you will start with your Exercise4A.gdb. This geodatabase already contains numerous
domains that were created with the USGS NHD data that is contain in the Exercise geodatabase.

1. Inthe Project pane, right click the Exercise4A geodatabase then click Design > Domains.

2. On the Domains tab, click New Domain.
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3. Name the Domain FENCE_TYPES, and use the Field type Text.

FENCE_TYPES

Text Coded Value Domain Default Default

4. Inthe Code Value portion or the Domains: Exercise4A Tab, enter the following code/value pairs:

1 Boundary
2 Cliff

3 Road

4 Stream

5 Unknown
6 Parking

7 Entrance

4 Code Value

1 Boundary
2 Cliff

3 Road

4 Stream

5 Unknown
6 Parking

7

Entrance

5. Click Save on the Domains tab to save the domain you created. Close the Domains: Exercise4A

tab.

6. Next, right click the Exercise4A.gdb geodatabase in the Project pane, then click Refresh.

7. Right click the TempFence Feature Class, and then click Design > Fields.

8. Under the Domain column on the Fields: Temp Fences tab, assign the FENCE_TYPES domain to
the TYPE Field.

TYPE

TYPE Text | FENCE_CoDEs - | 100

9. Click Save on the Fields tab to save the Domain Assignment.




In the next step, you will create a subtype that will categorize the TempFences layer by their material.

Step 4: Creating subtypes
1. Right click the TempFences feature class in the Project tab, and then select Design > Fields
2. Click Subtypes button on the Fields tab., then click Create/Manage
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3. Create a new subtype for the Fence_Material field using the following values in the Manage
Subtypes dialog:

Manage Subtypes - | X
Subtype Field: FENCE_MATERIAL
Default Subtype: Split Rail
Subtypes
Code Description
0 Split Rail

1 Barbed Wire

2 Electric

3 Wood - Picket

4 Wood - Horizontal Planks
5 Other/Unknown

4. Click OK on the Manage Subtypes dialog window, then click Save on the Subtypes tab to apply
the changes.

5. Close the Subtypes and Fields Designer tabs.

6. If necessary, remove the TempFences layer, and then add it to the map again.

4 | /| TempFences
FENCE_MATERIAL
— Barbed Wire
Electric
— Split Rail
Wood - Horizontal Planks
Wood - Picket

<all other values>

The tempFences layer now displays with the subtypes as a template in the Contents pane. The
tempFences layer does not contain any features, but when you edit you can chose what subtype to add.
Any feature you add will automatically inherit default values from the subtype.

7. Be sure to Save your project and keep ArcGIS Pro open.



Editing features and attributes

When you are editing in ArcMap, the interface tends to get cluttered with numerous toolbars that are
required for editing. In ArcGIS Pro, the same editing options that exist in ArcMap are available in a more
organized, cleaner ribbon interface. All editing operations are performed on the Edit tab, in context
menus and on toolbars, and in various editing-specific panes.

Feature templates in ArcGIS Pro set the properties that control the way layers are edited. For each
feature template, you can select a default tool and symbol, and set the default attributes for that layer.
When a feature is added, attributes will automatically update. One or more feature template can be
configured for the same layer. Generally, feature templates are used to create features with standard
attributes or unique value symbology. For example, different feature templates can be used for creating
wetland polygons on a layer that uses unique value symbology for wetland types like marsh, lake, pond,
riverine, emergent wetland etc.

ArcGIS Pro also provides templates called Group feature templates. Group feature templates refer to
existing feature templates, and can create multiple features on one or more layers in a single tasked
based operation. For example you can draw a water main feature and a fitting, gate valve, and meter all
at the same time.

Editing Basics and Group feature templates
ArcGIS Pro allows editing tasks with the following traits:

e The Edit ribbon contains most functionality

e The Edit session is the default session, in other words editing is always “on” for all editable
layers, you never need to start/stop editing or specify the edit target.

e Snapping is activated by a button at the bottom of the map display (not a toolbar). You set
snapping options with the button.

e The Create pane contains all feature templates and tools for feature creation.
e Edits can be saved or discarded either manually or automatically.
e You can use group feature templates to create features in many layers at one time.
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Exercise 2B: Editing features and attributes

Now that you have modified the schema for the TempFences layer, you will use editing tools to correct
an error in the Wetland layer and add a fence. The new fence is intended to help manage the areas
around the parking lot at the Woodpecker trail head.

In this exercise, you will perform the following tasks:

e Set Snapping.
e Create and modify simple features
e Edit attributes

Step 1: Edit the Wetlands layer

The wetlands layer in your map was obtained from downloadable sources, for this workshop, we are not
following any Agency guidelines and simply treating this content as hypothetical data that we can edit as
we see fit. For this example, the wetlands polygons around the Woodpecker trail are incorrect and need
to be merged. There are two Freshwater Forested/Shrub wetlands that should actually be connected in
a single feature that covers the area between the two original polygons.

1. Inthe Contents pane, right click the Trails layer and then click Zoom to Layer.

2. Right Click Edit tab on the ArcGIS Pro ribbon and made sure that Minimize the Ribbon is
unchecked (right click on the Edit tab). This will allow the Edit tab to stay open until you move to
a different tab.

3. On the Contents pane, click on the List by Selection icon.

d

4. Right click the Wetlands layer and then click Make this the only selectable layer.

5. On the Edit tab, use the Select Rectangle tool to select the Polygon on the Northern side of the
Woodpecker trail.




6. Use the Reshape tool to extend the polygon to overlap the wetland polygon on the southern
side of
the trail.

7. Double click to finish the Reshape tool input and reshape the polygon
8. Using the Select tool while the reshaped polygon is still selected, select the southernmost
wetland polygon so both (now overlapping) polygons are selected.

9. Click the Merge tool on the Edit tab to merge the two selected polygons into a single feature.



[Ty

Me‘rge‘

10. When the Modify Features pane opens, click Merge to run the merge process on the two

polygons. You should now have a single polygon covering the area around the Woodpecker trail.

11. Click Save on the Edit tab to save the changes you have made to the features.

Step 2: Create a new temporary fence using measurements.
A new section of fence is needed around the parking lot for the Woodpecker trailhead. The fence lines
were surveyed by a crew to get approval to build the fence.

1.
2.

9.

If necessary, turn on the Parking and TempFences layers.
In the Contents pane, select the Parking layer, then on the Map tab, click the Select by
Attributes button. This will open the Geoprocessing tab on the Select Layer By Attribute tool.
In the Geoprocessing tab, use the following parameters to select the desired parking lot:

e lLayer Name or Table View: Parking

e Selection type: New Selection

e Add Clause: Route_Name is Equal to Rattlesnake Hollow Parking
Run the Geoprocessing tool, and then close the Geoprocessing pane.
Right-click the Parking layer, and then click Selection > Zoom to Selection. You may need to
zoom back out to a slightly larger area (scale = 1:1,000)

Click the Snapping button at the bottom of the map and make Edge snapping the only selected
snapping option.

From the Edit tab, click the Create button to open the Create Features pane.

In the Create Features pane, click the Barbed Wire subtype, then click the right arrow.

— Barbed Wire
Al X A— O
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The arrow takes you to the Attributes form for the subtype you are creating.

10. For DESCRIPTION, enter Rattlesnake Hollow Parking Lot



11.

12.

13.

14.

Click the arrow in the Upper left corner of the Create Features pane to close the Active
Template.
Choose the Line construction tool to create a feature in the Barbed Wire subtype.

¥ TempFences
— Barbed Wire
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Add a start point for the new fence line using the following coordinates. With the Line tool
selected, right click on the map and select Absolute X,Y,Z...
Use the following coordinates:

e X:-9770750

e Y:4369655

The line is started with a vertex positioned at the coordinates you entered. Now using the survey
measurements.

15.

16.

17.
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20.

21.

22.
23.

Next, add a vertex using the Direction and Distance input with the following measurements:
e N 13-37-08E93’

Next, hover your cursor over the northern line of the Parking lot and then right click and select
Parallel, moving your cursor, you will see the line input is fixed to parallel to the Parking lot line
Right click again and select Distance...

e Use a distance value of 87’
Right click the map and then select Direction and Distance. Change the Direction type to P for
Polar. Enter the following values:

e 256-35-20 110’
Double click the line to finish the sketch.
On the Contents pane, double click the Barbed wire subtype symbol to open the Symbology
pane.
Set the line to Burnt Umber color (on Symbology > Properties tab), Dashed 6:6 (on Symbology >
Gallery), and the line width to 2.
Save your edits and Save your Project.
When completed your map should look like the following graphic:




Step 3: Update the attributes of the new fence
1. Select the fence line you just created if it is not already selected.
2. On the Edit tab, select Attributes to open the Attributes pane
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3. Clickin the TYPE field input box to activate the Domain pull-down list. Select Parking from the
list.
4. Click Save on the Edit tab to save your work.

Step 4: Create a new feature by tracing
The trail you want to add was built to separate trail users from the lake shoreline around the length of
the Woodpecker trail. The fence runs parallel to the trail and offset by 60 feet.

1. From the Contents pane, right click the Trails layer and select Zoom To Layer.
2. On the Edit tab, click Create to open the Create Features pane.
3. Inthe TempFences layer > Split Rail subtype enter the following attributes so they are updated
automatically when you add the new fence:
e FENCE_MATERIAL: Split Rail
e TYPE: Boundary
e DESCRIPTION: Fence separating trail from wetlands
4. Create a new Split Rail fence by tracing the south side of the trail with a 60 foot offset.

The Trace tool does not require you to select the feature before you trace it.
]
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Select the Trace tool, then click “O” on your keyboard to access to Trace Options dialog box.

Set an Offset of 60 feet.

On the Options dialog boxes, also select check on the option to Remove self-intersecting loops.

Starting at the Trailhead, begin tracing the trial along the south edge, all the way around the

train until you finish near the trailhead.

5. Trace counter clockwise all the way around the trail and finish at the junction where the trail
closes near the trail head.

6. Double click to finish the sketch.
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7. Once the Split Rail fence line is complete, there is an area where the 60 foot offset extended the
fence into a lake/pond on the north side of the trail.

8. To fix this overlap, you will use the Reshape tool with the trace tool to follow the shoreline
where the overlap exists.

9. With the Reshape tool active, click on the split-rail fence line you just created. This will select
the feature in reshape mode.

10. From the popup tools menu, select the Trace tool.

11. Press the “O” key to open the Trace Tool options. Uncheck the Trace with Offset option.

The Reshape tool requires that you intersect a line feature in two places, everything you draw between
the two points of intersect will replaced the existing sketch.

12. Click the cursor on the line between the two wetlands polygons on the outside of the Split-rail

fence line, then trace to an area outside the Split-rail line on the other side of the overlap (start
at point A, then trace to point B).




13. Double click the cursor to finish the Reshape operation.
14. Your line should now appear as shown below:

15. Save your edits.

For the last edit step, you need to update an attribute for both of the fence lines you have added. You
have several options for editing attributes including using the Attribute pane, or calculating fields in an
attribute table.

1. Right click the tempFences layer in the Contents pane and then click Selection > Select All.
2. On the Edit tab, click on the Attributes button to open the Attributes pane.

You should have two fence features selected and showing in the Attributes pane. The top portion of the
Attributes Pane shows the selected features listed by ID. If you select any listed feature, you can then
use the Attributes fields to update values. Clicking on the Feature Class name in the Attributes pane
allows you to update attributes for all of the selected features.

Attributes S
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3. Click on the TempFences feature class in the Attributes pane (not the individual feature id’s)
4. Inthe SOURCE field, enter 5 for a value. In this exercise the value 5 represents screen digitized
source.

You have now created, edited and updated attributes on a feature in ArcGIS Pro. The tools used in this
exercise are only a few of the robust toolset available in ArcGIS Pro.



End Exercise 4



