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Exercise 1 – Introduction to Raster Analysis and Spatial Analyst 
Toolbox 


 
 
Session Objectives:  At the conclusion of this session, you will be able to: 


 
 
 


 Preform suitability analysis using raster data 
 


 Reclassify raster layers  
 


 Build Map Algebra expressions  
 


 Set Project environments within ArcToolbox 
 


 Use a variety of spatial analysis tools to modify raster layers 
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Material Created By:  Amy Keister (Nov2012) 
 
Modified: Mark Richardson (Nov 2012) 
 
Software:  ArcGIS 10, SP5 
 
Directory Path: D:\CSP7300\Exercise1  
 
GDB:   
 
Imagery:  
 
MXDs: WhiteRiver.mxd 
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PART 1 – Introduction to Raster Data  


All data are located in D:\CSP7300\Exercise1\WhiteRiver, unless otherwise noted. 


 


Section 1: Create a forest canopy raster layer  


 Launch ArcMap and open the WhiteRiver.mxd 


- Notice the “2001_Forest_01.img” raster.  It is a binary raster (it only has values of 


0 and 1).  In this raster forest = 1 and everything else = 0 


- The “canopy_cover.img” raster. It is a continuous raster with values that range 


from 0 – 100 


- We need a raster that only shows canopy cover on areas where there is forest. 


Because the forest layer is binary and the forest values = 1 in that layer, we can 


just multiply these two layers together to get the forest canopy cover raster. 


 Open the Raster Calculator tool (Spatial Analyst – Map Algebra) 


 Double click the “canopy_cover.img” raster to add it to the middle box 


 Click * to add the multiply symbol to the middle box 


 Double click the “2001_Forest_01.img” 


- The equation should read "canopy_cover.img" * "2001_Forest_01.img" 


 Save your output as “Forest_Canopy.img” 


 


 


 Hit OK 


 Explore the output raster 
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Section 2:  Calculate percent forest in a neighborhood 


 Open the focal statistics tool (Spatial Analyst – Neighborhood).  We can use it to 


calculate the percent forest in a 250 m radius circle 


 Use “2001_Forest_01.img” as the input raster 


 Save the output raster as “PercentForest.img” 


 Use a Circle Neighborhood 


 Click to change from “Cell” to “Map” units.  Notice how the number for radius 


changes 


 Use 250 as the radius 


 Use “mean” as the Statistic type 


 


 


 Hit OK 


 Explore the output raster 


- Why were we able to use a “mean” on this dataset to get percent forest? 


  







GIS Design II: Data Analysis and Model Building                                                                                    2012 
U.S. Fish and Wildlife Service                              National Conservation Training Center 


 


Spatial Analyst                                                                                       5 


Section 3:  Explore habitat richness in a neighborhood 


 Open the focal statistics tool (Spatial Analyst – Neighborhood).  Let’s explore using 


the “Variety” statistic on the landcover dataset. 


 Use “2001_NLCD.img” as the input raster 


 Save the output raster as “NLCDVariety.img” 


 Use a Rectangle Neighborhood 


 Use 9x9 cells as the Neighborhood settings 


 Use “variety” as the Statistic type 


 


 


 Hit OK 


 Check out the output raster. 


-  What do you think it represents?  


- Think about how the type of input raster (binary, thematic, continuous) will impact 


the result of a neighborhood function. 


- Check out the other neighborhood statistic types that are available. 


- How might you use these? 
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Section 4:  Calculate the area of each landcover type in each watershed   


 Open the Tabulate Area tool (Spatial Analyst – Zonal).  This tool is often useful for 


thematic data 


 Use “WBD” as the Input feature zone data 


 Use “Huc_12” as the Zone field 


 Use “2001_NLCD.img” as the Input raster class data 


 Use “Value” as the class field 


 Save the output table as “WBDTabAreaNLCD” 


 Hit OK 


 Open the output table and explore.   


- What are the units for the values in the table?  


 Join the table with the WBD layer by right clicking on WBD and selecting Joins and 


Relates/Join 
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 Change the symbology of the WBD layer to display Quantities using Graduated 


colors and the field value of “Value_90” 


 In the NLCD landcover, 90 = woody wetlands.  In the “WBDTabAreaNLCD” table, 


the “Value_90” field contains the area (sq meters) of woody wetland landcover type 


in each HUC 12 watershed 


- As you can see in the graduated color display, there is more woody wetland area 


in the watersheds that overlap the White and Cache River NWRs 


 


Section 5:   Joining the zonal statistics table 


 Open the Zonal Statistics as Table tool (Spatial Analyst – Zonal).  This tool is often 


useful for continuous data 


 Use “HabitatInventoryStands” as the Input feature zone data 


 Use “Join” as the Zone field 


 Use “Forest_Canopy.img” as the Input value raster 


 Save the output as “ZonalStand” 


 


 


 Hit OK 


 Open the “ZonalStand” table and explore 


 Join “ZonalStand” with the “HabitatInventoryStands” layer 


 Change the symbology of the “HabitatInventoryStands” layer to display 


Quantities\Graduated colors using the Field value “Mean” 
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- This displays the mean forest canopy cover per habitat stand 


 


- Why did we use a tabulate area for the thematic NLCD data, but a Zonal 


Statistics for the continuous canopy cover data? 
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PART 2: Calculating Pine Stands Acreage 


All data are located in D:\CSP7300\Exercise1\StMarks, unless otherwise noted. 


 


Section 1: Setting project environments 


 Launch ArcMap and Open the StMarks.mxd 


 Set Environments for this project by right clicking in a blank area of ArcToolbox  


 


 Set workspace and scratch workspace 


 Go into processing extent and choose to Snap to the Florida landcover raster 


 


Section 2: Generate a subset of the Florida Landcover  


 Zoom to the “St Marks_acquired” layer  


 Open the Raster Calculator tool (Spatial Analyst Tools – Map Algebra)  


- First we will change the Environment Settings for just this tool 


 Change “processing extent” to “Same as Display” and hit OK 


- This will change the environments for just this use of the tool 


 Now we are going to multiply the fl_veg03 raster by 1 


 Double click on fl_veg03 in the left hand box.  You will see “fl_veg03” appear in the 


middle box 


 Click once on the multiply sign to add it to the equation 


 Click once on the number 1 to add it to the equation  


- Now you have the equation "fl_veg03" * 1 in the middle box 


 Save your output raster as “StMarkVeg” 
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 Hit OK 


 


Section 3 – Verification of the Subset 


In Section 2 we used a combination of map algebra and environment settings to subset our 


image. By using this method, we were able to set the snap raster so the cells in our subset 


raster line up with the cells in the original dataset.   


 


 Zoom out one step to see that the raster has been subset 


 Now zoom in very close to one corner of your subset raster to see that the snap to 


raster worked 


 You can also right click on the Florida Veg Raster in the table of contents and 


choose data\export data, which is handy, but you can’t snap to your original raster 


with that method   
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Section 4: Create a pine vegetation raster layer 


The landcover classes that are pine associated are: sand pine scrub (Value 4), sandhill 


(Value 5), mixed pine-hardwood forest (Value 7) , and pineland (Value 9). The standard 


way to do this is to use the Reclassify tool (Spatial Analyst – Reclass). 


 
 Use “StMarkVeg” as the input raster 


 Use “Value” as the Reclass field 


 Click on the “Unique” button to get all available classes listed in the “Old Values” 


column 


 Now manually go through and change all the values in the “New Values” column to 0 


except for the values 4, 5, 7 and 9 


 Save the output file as “PineVeg” 


 Hit OK 
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Section 5: Calculate the area of pine within each Refuge tract.   


 Open the Tabulate Area tool (Spatial Analyst - Zonal Statistics)  


 Use “StMarks_acquired” as your input feature zone data 


 Use “Tract_exmpl” as your zone field 


 Use “PineVeg” as your Input raster class data 


 Use “Value” as your class field 


 Save your output table as “PineVegTabArea” 


 Hit OK 


 Open the resulting table in ArcMap.  See that it has 4 fields 


 


 


 


 


 


 


 


 


 


 


 


- The “Value_1” field contains the area (in square meters) for pine associated 


vegetation in each of the refuge tracts.  


 


- If you want to see the values in acres instead of sq meters you can add a 


new field and calculate the acreage by dividing the sq meters by 4047) 


 


- Result yields 6 total units with 14,399 acres of pine associated forest  
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PART 3: Locating where you can Burn within St.Mark’s NWR 


 Subscribed Burn Criteria  


 All burns must be on refuge lands only 


 The landcover must be a pine associated landcover 


 The area can’t be within 0.5 km of a high impact urban landcover 


Section 1: Identifying high impact urban areas 


The High Impact Urban class has a Value of 41.  This time we are going to create a new 


raster layer where we change all the cells with a value of 41 to 1 and change all the other 


cells to NoData.You can do this with the Reclassify tool you learned earlier. 


Because it takes a while to change all 43 values in the Reclass tool I’m going to use a 


conditional tool to create the new raster instead. 


 Open the Con tool (Spatial Analyst – Conditional) 


 Use “StMarkVeg” as the Input conditional raster 


 Use “’Value’ = 41” as the expression 


 Use “0” as the true constant value 


 Leave the false raster or constant value blank 


- If you don’t put a value in for the false value you get NoData for the false 


value 


 Save the output as “Urban” 


 


 Hit OK 
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Section 2: Create a distance raster layer 


The Euclidean Distance tool calculates the straight line distance from any and all 


NoData cells to the nearest source cell with any value (to include 0), up to a specified 


maximum distance. This is another reason for the Reclassify above, so now our only 


source cells are the High Impact Urban cells (value = 0) 


 Open the Euclidean Distance tool (Spatial Analyst – Distance) 


 Use “Urban” as the input raster source data 


 Save the output as “Urban500” 


 Use a max distance of 500 (the units will be meters) 


 


 


Section 3: Reclassify distance to urban raster 


Reclassify “Urban500” from a continuous raster (values 0-500,NoData) to a thematic raster 


(0,1) in order to have available a “no burn” exclusion area for later steps  


 Use the Reclassify tool (Spatial Analyst – Reclass) we learned earlier to do this 


 Use “Urban500” as the Input raster 


 Use “Value” as the Reclass field 


 Click on the “Classify” button 


 Change the number of classes to “1” and leave everything else the same.   


 Hit OK to close out of the Classify window 


 Change values 0-500 to 0  


 Change values NoData to 1 


 Save output as “urbanmask” 
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 Hit OK 


 Check out the output. This created a raster with values of 0 within 500 meters of 


High Intensity Urban and values of 1 everywhere else.  This is going to be useful as 


a mask in later steps. 


- If you want to explore, you could also the IsNull command which makes the 


NoData from the Distance Raster 1 and everything else 0 


 


Section 4: Create a pine layer within the Refuge boundary 


 Use the Extraction by Mask tool (Spatial Analyst – Extraction) to return PineVeg 


restricted to the St. Marks boundary 


 Use “PineVeg” as the Input raster 


 Use “StMarks_acquired” as the Input feature mask data 


 Save output as “PineVegSM” 


 


 Hit OK 
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Section 5: Calculate the acreage of pine forest that can be burned 


Use Raster Calculator (Spatial Analyst – Map Algebra) to multiply PineVegSM with 


UrbanMask from Step 4c to obtain a burnable refuge pine veg data layer 


 Save the output as “BurnMe” 


 


 


 Hit OK 


 This works because of the way we used 0 and 1 values when creating our rasters in 


previous steps (any number times 0 = 0) 


 If you want to be quicker, you can take your pine associated raster “PineVeg” * 


“urbanMask” and use environment settings to set an analysis mask to the refuge 


boundary.  This lets you skip the extract by mask step. 


 Review the raster attribute table to determine that 41,546 pixels remain available for 


burning.  


 


  41546 pix * 900 m2/pix / 4047 = 9239 ac 
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PART 4: Prioritizing your prescribed burn areas 


Section 1: Identify the dominate landcover in a focal area  


 Use the Focal Statistics tool (Neighborhood - Focal Statistics) to identify the 


dominate landcover class in a 1 km radius circle 


 Use “StMarkVeg” as the Input raster 


 Save the Output as “VegMaj” 


 Use a Circle Neighborhood 


 Use a Radius of 1000 Map Units (meters) 


 Use Majority as the Statistics type 


 


 Hit OK 
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Section 2: Identify areas where the sandhill landcover is the dominate component  


Reclassification is done to save only the pixels where the sandhill (Value 5) class is the 


dominate landcover. You can use the Reclassify tool here, but we are going to use a con 


again (Spatial Analyst – Conditional) because it saves time. 


 Use VegMaj as the Input conditional raster 


 Use “Value” = 5 as the expression 


 Use 1 as the true value 


 Use 0 as the false raster 


 Save the output as “VegMajLLP” and hit OK. 


 


 


Section 3: Calculating the priority burn areas 


Multiply the majority sandhill layer (VegMajLLP) with the burnable refuge pine layer to 


obtain a priority burn layer 


 Use Raster Calculator (Spatial Analyst – Map Algebra)  


 Use the equation "VegMajLLP" * "BurnMe" 


 Save the output as “PrtyBurn” and hit OK. 
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 Review the attribute table of output layer to see that 6519 pixels qualify as priority for 


burning.  


6519 pix * 900 m2/pix / 4047 = 1450 ac 


 


 Go back and review all of the steps we took in Part 2 and 3.  See how the choices 
we made for many of the outputs saved us from having extra processing steps along 
the way.  This is just one reason why it is important to plan out your project using a 
technique like Eric’s “Sample GIS Project Summary” before you get started with an 
analysis. 
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Exercise 2 – Introduction to Modelbuilder 
  
 
 


Session Objectives:  At the conclusion of this session, you will be able to: 
 


 
 
 Understand how models affect workflow and transparency 


 
 Create a new toolbox and model 


 
 Load data and tools into a model, create outputs 


 
 Use the Reclassify, Focal Statistics and Combine tools in a model 


 
 Copy and modify pieces of existing models to increase efficiency 
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Material Created By:  Gabe DeAlessio (Dec 2012) 
 
Software:  ArcGIS 10, SP5 
 
Directory Path: D:\CSP7300\Exercise2 
 
GDB:  GWWA.gdb 
 
Imagery:  
 
MXDs: GWWA.mxd 
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SECTION 1 – Set Up (together with class) 
 
All data are located in D:\CSP7300\Exercise2 folder, unless otherwise stated. 
 
The Golden winged Warbler is a species that lacks habitat across its nesting range.  The 
Joint Venture recovery plan calls for another 200,000 acres of habitat in BCR 12 in 
Minnesota alone.  We will look at the landscape and evaluate areas that currently meet the 
habitat requirements as a way to focus protection. 
 
The Golden-winged Warbler Recovery Plan states the following: at the macro landscape 
context, GWWA prefers 70% forest and 22% open, herbaceous landcover within 1.5 
miles.   
 
Using these requirements, we will create a model that selects the macro-habitat landcover. 


 
1. Open the GWWA.mxd. 


 
2. Note the following 2 pieces of data are already added: 


 
1. Study area  
2. 2006 NLCD 
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3. If ArcToolbox isn’t open, click on the button to open. 
 


 
 


4. Right Click in ArcToolbox and select “Add 
Toolbox”  
 


5. Browse to Exercise2 and click on the “New 


Toolbox” Icon .  Name it “CSP7300 Tools”, 
then highlight it and Click Open. 


 
You now have an empty toolbox ready to add 
custom models and scripts into. 
 
 


6. Right click on CSP7300 Tools and select New / 
Model. 
 
An empty Model page will open.   
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SECTION 2 – Simple Model Construction (instructor then student) 
  


1. Position your ArcMap and Model Builder window so you can see both.   
 
Drag the Study Area feature class from the table of contents into your model.  
Notice it turns to a blue oval, which by default represents a data input. 
 


2. Next add the Buffer tool to the model.  In ArcToolbox, find the Analysis Tools / 
Proximity / Buffer.   


 
Drag the tool onto the model.  Note the tool is rectangular and a connected oval is 
also added.  They are uncolored as you have not specified how they will work yet.  
You’re model should look like this: 


 


 
 


3. Connect the StudyArea to the Buffer Tool.  First, select the Connect tool, then left 
mouse click inside the StudyArea, move the line into the Buffer tool and click again.   
 


 
 


 Choose “Input Features” from the pop up to designate the StudyArea as the input 
for the tool to run. 
 


4. Next, double click on the Buffer Tool.  This opens the Tools diaglog box.  Set your 
output to the GWWA geodatabase and your buffer distance to 1.5 miles.  Click OK. 
 
Note: because our criteria looks at data within 1.5 miles, we need to expand our 
analysis area beyond the study area to yield accurate results. 
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5. Your model should now be colored in, indicating it’s ready to run.  Right Click on the 
green oval, StudyArea_buffer and make sure “Add to Display” is checked. 
 


 
 


6. Under Model, choose Save.   
 
Tip: Always Save BEFORE running a model or risk losing work should the model 
encounter an unexpected error! 
 


7. Finally, run the model by clicking on the Run icon  or going to the Model menu, 
and choosing Run. 


 
8. You’re model should run quickly and add to your map. Also notice the model 


elements have a shading behind them, indicating those processes have been run.  
 


9. Change symbology of the Study Area Buffer to hollow out the outline. 
 


 
 
STOP HERE 
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SECTION 3 – Additional Model Construction (instructor then student) 
 
In this section we will fully develop our model based on the landcover requirements for the 
Golden Winged Warbler.  Because the warbler requirements use 2 different habitats, our 
model will split into 2 courses and combine them at the end. 


 
1. With your model open, Drag the NLCD2006 data onto it. 


 
2. Find the Clip Tool in ArcToolbox / Data Management / Raster /Raster Processing.  


Drag and drop it into your model. 
 


3. Use the Connect tool to add the Study Area Buffer as the ‘output extent’ and the 
NLCD 2006 as the ‘input raster. 


 


 
 


4. Double click on the Clip tool and verify your settings.  Check on the “Use Input 
Features for Clipping Geometry”.  Set the output to go into the GWWA.gdb and 
name it NLCD2006_Clip. 
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5. Run the model so far.  This will create the data that we will use in the next step.  
Without running the model, the Reclassify wouldn’t have data to drive on! 
 


6. Add the Reclassify tool to the model.  It can be found in ArcToolbox / Spatial 
Analyst Tools / Reclass 
 
Tip: Expand your model window as needed. 
 
We will use the Reclassify to “flag” the appropriate forest habitats from the NLCD. 
 


7. Connect the NLCD 2006 Clip to the Reclassify tool, specifying it as the ‘input raster’. 
 


8. Double click on the Reclassify to open the tool dialog box. In the dialog box, click on 
“Unique” to get the list of NLCD values. 


 
9. In the “New values” column, make the following values 1 and all others 0: 


 
41 – Deciduous Forest, 42 – Mixed Forest, 90 – Woody Wetlands 
 
Specify the output into the GWWA.gdb, named Reclass_Forest 
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10. Add the Focal Statistics Tool to the model.  It can be found in ArcToolbox at Spatial 
Analyst Tools / Neighborhood  
 
Focal Statistics is a powerful analytical tool that looks at each pixel and quantifies 
the pixels around it based on your criteria.  We will use it to determine the amount of 
“Forest” within 1.5 miles of each pixel. 
 


11. Connect the Relass_Forest to the Focal Statistics Tool.  Set the output to the 
GWWA.gdb named Focal_Forest 
 
Set the Neighborhood to Circle with a Radius of 80. 
 
Set the Statistics type to “Sum”.  Since all values are 0 or 1, we will get a count of all 
Forest pixels. 
 
Check on Ignore NoData. 
 
Why 80?  A 30 meter pixel equates to ~98.4 feet.  Since 1.5 miles is 7920 feet, we 
need to examine 80 pixels in all directions. 


 


 
 


12. The next two steps we will take our Focal Stats value and convert it to a 
percentage.   
 
Drag the Add Field tool to the model.  It can be found in ArcToolbox \ Data 
Management \ Fields 
 
Drag the Calculate Field tool to follow the Add Field tool. 
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13. Connect the Focal Forest to the Add Field.  Double click on the tool and set the 
Field Name to “F_Perc”.  Leave Field Type as Long and all other settings as is. 
 


 
 


14. Connect the Focal_Forest(2) to the Calculate Field tool. 
 
Double click the tool and set the Field Name to the newly created F_Perc. 
 
Using the calculator button, input the expression: ([VALUE] / 20081 )* 100 
 
Why 20081?  This is the amount of 30 meter pixels contained within a 1.5 mile 
buffered area. 
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15. Save your model. 
 


16. Click Run Model.  This should take a minute to complete.  Be sure your model 
completes without errors.  If you get errors, review the error and correct. 


 
17. After running, we have to add an additional Reclassify step.  We have to convert the 


Forest Percent (F_Perc) field to VALUE.  This is because many of the raster tools 
run solely on the value field rather than additional table fields. 


 
Drag and drop the Reclassify tool into the model. (see step 5 is you forgot where it 
is.) 
 
Connect the Focal_Forest(3) to the Reclassify. 


 


 
 


18. Double click to open the tool.  Change the Reclass Field to F_Perc. 
 
Now click Unique.  Because we already converted the values to an integer, all the 
values line up, 0 to 0, 1 to 1, etc. 
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Change the output to GWWA.gdb  and name it For_Final 
 


 
 
The result is converting the F_Perc field INTO the Value field, so it can be properly 
processed later. 
 


19. Make sure to Save your model.  It should look like a long flowchart: 
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SECTION 4 – Additional Model Construction – Repeat for Open Land (instructor then 
student) 
 


1. We will now effectively repeat steps 4 – 18, this time focusing our reclassification on 
Open Lands rather than Forest.  This can be done by either individually adding each 
element again OR using a simple copy/paste of all the elements. 
 
Using the Select tool, highlight the everything to the right of the NLCD 2006 Clip. 
 
Copy and paste, moving the elements underneath the originals.   


 


 
 


2. Starting with the newly copied Reclassify(3), double click the tool and modify the 
Unique Values to reset all Values to 0, except the following: 
 
71 – Grassland, 81 – Pasture/Hay, 95 – Emergent Herbaceous Wetland 
 
Change the Output raster to:  Reclass_Open 
 


 
 


3. When you click OK, notice the green oval Output is renamed. 
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4. Double Click the Focal Stastics (2).  Here we only need to modify the Output rater 
Name to Focal_Open. 


 


 
 


5. Double click the Add Field(2) tool, and adjust the field Name to O_Perc (open 
percentage) 
 


6. Double click the Calculate Field tool, and adjust the Field Name to O_Perc.  The 
formula remains the same. 


 
7. Use your Select tool to delete the connection between the Focal_Open(3) and the 


Reclassify(4) tool.  Because we have not yet run this model to this point, we cannot 
get the values or reclassify them. 


 


 
 


8. With the connection disabled, Save the model and Run. 
 
If you get any errors, review them and fix as necessary. 
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9. Next, reconnect the final Reclassify using the Connect tool.  Be sure to specify the 
Reclass field as the O_Perc field (not Value!). 
 
Change the output name to Open_Final. 


 
  Click the Unique button. 


 


 
 


10. Run the the model again to finish the last reclassify.  At this point, all the model 
should be run. 
 


11. In order to easily analyze the data, we will add one final tool to the model called 
Combine.  Find the Combine tool in Spatial Analyst Tools / Local and drag it to the 
end of the model. 


 


 
 


12. Use the Connect tool to add the For_Final and Open_Final to the Combine. 
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13. Set the Output to Forest_Open, and click OK when complete. 
 


 
 


14. Right Click on the Forest_Open green oval.  Check “Add to Display” on. 
 


15. Save and Run the model. 
 


 
 


16. At this point, the model is complete and has been run, and you should have a 
Forest_Open raster in ArcMap.   
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What does the raster as-is show?  
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SECTION 5 – Evaluating the Output 
 
Because the Value field is nothing more than a counter for unique combinations of percent 
forested and percent open, you have to dig a little deeper to get useful information out of the 
output. 
 


1. In the ArcMap Table of Contents, Right click on the Forest_Open and Open 
Attribute Table. 
 


2. Note that in addition to the Value and Count columns, the Combine tool also 
returned the For_Final and Open_Final columns. 


 
These values hold the key to our analysis! 
 


 
 


3. Use the Select by Attribute in the table menu and start a selection query.   
 
Remember the GWWA habitat requirements:  70% of Forest and 22% of Open land. 
 


4. Construct a query based on the exact requirements. 
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How many pixels are selected?  _______________ 
 
Our model yielded a pretty small amount of area using the exact specifications.  
Since we’re modeling, and using coarse data, and nature tends to have a bit of 
wiggle room anway; let’s increase the amount of forest and open space to give a bit 
of a range. 
 


5. Change the Select by Attributes to query plus or minus 5% for both forest and open 
land. 
 
("For_Final" > 65 AND "For_Final" < 75) AND ("Open_Final" > 17 AND 
"Open_Final" < 27) 
 


 
Now how many pixels are selected?  __________________ 
 
Hint: Right click on Count and use Statistics 
 
 
How many acres does that equate to?  __________________ 
 
Try an online site like http://www.onlineconversion.com/ if you’re stuck. 
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6.  Congrats, you have identified the areas which may be priorities for protection! 
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Exercise 3 – Suitability Modeling  
 
 
Session Objectives:  At the conclusion of this session, you will be able to: 


 


 Create suitability models for windfarms in West Virginia using Boolean Overlay, 
Index Overlay and Fuzzy Logic Membership techniques and interpret the 
results. 
 


 Weight selection criteria using point allocation and ranking methods. 
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Material Created By:  Mike Strager (Dec 2012) 
 
Revised: Eric Kelchlin (Dec 2012) 
 
Software:  ArcGIS 10, SP5 
 
Directory Path: D:\CSP7300\Exercise3\suit-modeling 
 
GDB:  all shapefiles 
 
Imagery: demutm 
 
MXDs:  
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Part A – Suitability Modeling 
 
This lab covers boolean overlay, index overlays, and suitability modeling with fuzzy 
membership functions.  The example is for site analysis of windfarms in north central 
WV.   
 
All data are located in D:\CSP7300\Exercise3\suit-modeling, unless otherwise 
noted. 
 
General instructions are provided for most of the lab lesson.  Please ask if you have any 
questions. 
 
Creating Analysis Grids 
 
1. Launch ArcMap.  Make sure you have the Spatial Analyst extension activated. 
 
2. Add the following datasets from the suit-modeling folder. 
 


 demutm (digital elevation model for the study area) 
 airports  
 power (electrical powerline network) 
 major-roads 


 
For our site suitability model, the overall goal is to find areas that are most suitable for 
windfarm construction.  The following objectives will be applied to our model: 
 
 Windfarms should not be too close to an airport. 
 Windfarms should be placed on predominantly western facing slopes to capture 


prevailing winds.  
 Windfarms should be on higher elevated areas. 
 Windfarms should have power line networks available to link to interstate grids. 
 Windfarms should be placed at sites to minimize their visibility from major roads. 


 
To find the suitable areas that meet these objectives, we will need to use the functions 
in the Spatial Analyst toolbar to create 4 new raster datasets.  These include an aspect 
grid, a grid of distances from powerlines, a grid of distances from airports and a visibility 
grid showing degree of visibility from the roads.   
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3. Open the Environment Settings in the Geoprocessing tab. 
 
 Set your Workspaces to D:\CSP7300\Exercise3. 


 Set the Processing Extent to the demutm. 


 Set the Raster Analysis Mask to the demutm and the Cell Size to maximum of 


inputs.  These options are set to make sure our model runs only for the study 


area we want. 


 
4. Create Distance Grids:  
 


 Create distance grids using the Euclidean Distance command to find straight line 
distance grids from the airports and power line shapefile.   
 


 Call the outputs dist2airports and dist2power.  Make sure to keep the cellsize 
at 30m. 


 
 The output grids from running these two functions will create raster grids in 


meters. 
 
5. Create an Aspect Grid:  
 


 Create an aspect grid from the demutm layer. Call it asp in the table of contents. 
 
6. Create a Visibility or Viewshed Grid:  (this will take about 10min to run) 
 


 Use the viewshed command and specify the demutm elevation grid as the input 
raster and the major-roads shapefile as inputs.  Call the output visibility.   
 


 
 


 
The result will show a legend of visible and non-visible areas (0 values) from the road 
vertices.  The higher the number in the grid, the more visible the cell location is from the 
roads.  The numbers correspond to the number of different sites along the road that can 
see the cell location.   
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Boolean Overlay 
 
Following the objectives stated on the first page of this lab exercise, we will now create 
criteria grids for the model to find suitable areas for windfarms. 
 
1. Use the Raster Calculator to build expressions (one at a time) to find: 
 


 Areas that are more than 800 meters in elevation 


 Areas that are more than 1 mile (1600 meters) from airports 


 Areas that are 2 miles (3200 meters) or less from power line networks 


 Areas that can be seen from 8 sites or less along the major roads (<= 8) 


 Areas that are on westerly facing slopes (202 to 338 degrees).  
 


NOTE: in ArcGIS 10, the raster calculator requires that expressions have ( ) around 
them such as ("asp" >= 202) & ("asp" <= 338) 
 
 
IMPORTANT:  the raster calculator will create output grids resulting in cells = 1 true 
meeting the expression or 0 = false not meeting the expressions outlined above.  You 
should rename the grids once the calculation is run so you remember the grid output.  
The alias names of the grids in the table of contents can have spaces and an unlimited 
number of letters but the saved grid names should never have spaces and be limited to 
12 characters in their folders! 
 
 
2. Rename the grids appropriately in the table of contents after each of the raster 


calculations are run.  For example: 
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Finding suitable areas 
 
Because each grid has a value of 1 where the expression was true and 0 where the 
expression was false, we can now use the boolean AND operator to find all areas in 
which all the criteria are true. 
 
1. Use the raster calculator with the & operator to find the suitable areas.   
 
2. I have decided to call mine boo-result.  You will use this grid again to answer some 


questions and make a map comparing it to the other suitability modeling 
approaches. 


 


 
 
 
Index Overlay 
 
In this part of the exercise you will develop a suitability model using the same grid data 
(aspect, dist2power, dist2airports, visibility, and demutm) and objectives, but you will 
reclassify the grids to fit 5 classes.  This makes it possible to combine the various grid 
layers together that originally contained noncommensurate data values.   
 
In Part A we converted all the of different criteria grids into [1, 0] values in order to 
combine them.  Using the same general rules as in Part A, you will now reclassify the 
grid datasets and assign new utility scores to the values as indicated below.   
 
As a general rule in the utility scores, a value of 5 is preferred over a value of 4, 3, 2, 1 
and 0 is not acceptable.  We need at least three reference scores in the 1 to 5 range (ie 
1, 3, 5) not counting the 0 criteria. 
 


 
1. Starting with the demutm layer first, select the Reclassify Tool (Spatial Analyst > 


Reclass) and click the Classify  button. 
 


 Change the Method to Equal Interval and change the number of classes to 6.   
 


 Set the number of breaks to match the cutoffs you want.  Start at the highest 
number and work your way down.  When finished the new Reclassify dialog box 
will have the six breaks. 
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 Set the utility scores (0 for the values that are not acceptable and then at least 
three scores in the 1 to 5 range.  Make sure the 800–900 range has a value of 1. 


  


 
 


 Name this new grid elev scores in the table of contents 
 


 







GIS Design II: Data Analysis and Model Building                                                                                   2012 
U.S. Fish and Wildlife Service                              National Conservation Training Center 


 


Suitability Modeling                                                                                      8 
 


2. Repeat the same process for the dist2airports grid using the values shown below. 
 
Utility scores to use: 
 
Reclasss the distance to airports (dist2airports) 
Values   Reclassed score 
0 to 1600  0    
1600 to 3200  1    NOTE: a distance of 1600 will be a 1 
3200 to 4800  2 
4800 to 6400  3 
6400 to 8000  4 
Above 8000  5 
 
Call this new grid airport scores in the table of contents 
 
 
3. Now that you have a handle on manually entering the scores, let’s speed things up a 


bit on the last 3 grids.   
 


 Reclassify the dist2power grid, but this time select the Load  button and 
browse to the power_source table in the Index_Overly folder.  Select Load and 
OK. 


 
 


 Repeat the same process for the visibility and asp grids.  The tables to load are 
called visibility_scores and asp_scores, respectively.  Rename the grids in the 
table of contents as listed below. 
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Reclassify the distance to powerline networks (dist2power) 
Values   Reclassed score 
0       to 1600  5 
1600 to 2000  4 
2000 to 2400  3 
2400 to 2800  2 
2800 to 3200  1    NOTE: a distance of 3200 will be a 1 
Above 3200  0    
 
Call this new grid power scores in the table of contents 
 
 
REMEMBER THAT WE DON’T HAVE TO USE ALL VALUES FROM 0 TO 5 BUT DO HAVE TO 
USE AT LEAST THREE NOT ZERO IE (5,3,1) 
 
Reclassify the degree of visibility from the roads (visibility) 
Values   Reclassed score 
0 to 1   5   
1 to 2    4   
2 to 4   3   
4 to 6   2   
6 to 8   1     NOTE: a visibility value of 8 will be a 1 
Above 8  0      
 
Call this new grid vis scores in the table of contents 
 
NOTE THAT THE ASPECT GRID NEEDS 7 CLASSES FOR THE 0 TO 5 RANGE 
 
Reclassify the areas that are west facing slopes (asp) 
Values   Reclassed score 
0 to 202  0 
202 to 229  1 
229 to 256  3  
256 to 283  5 
283 to 310  3 
310 to 338  1 
338 to 360  0 
 
Call this new grid aspect scores in the table of contents 
 
 
4. When you have all the grids finished, use the raster calculator to multiply them all 


together and name the output index-result.  You will use this grid again to answer 
some questions and make a map comparing it to the other suitability modeling 
approaches.  
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Fuzzy Logic Membership Functions 
 
In this part of the exercise you will develop a suitability model using the same grid data 
(aspect, dist2power, dist2airports, visibility, and demutm) and objectives, but will give 
utility scores using fuzzy membership functions.   
 
As a general rule in the utility scores, a value of 1 is most preferred while 0 is not 
acceptable.   
 
The con function in ArcMap acts as an if – then - else statement.  It is very useful for 
creating the fuzzy membership functions. 
 
YOU COULD COPY / PASTE THE FORMULAS INTO THE RASTER CALCULATOR IF 
YOU GET THIS WORD DOCUMENT DIGITALLY.  BE CAREFUL BECAUSE 
SOMETIMES THE QUOTES “ WILL BE DIFFERENT AND SO WILL THE – SIGN 
FROM MS WORD TO ARCMAP!  You may have to retype all the quotes and minus 
signs in the raster calculator if you get an error message. 
 
Membership functions to use: 
 
1. Use the raster calculator on Elevation (demutm)   
 


Con("demutm" < 400, 0, Con("demutm" > 1200, 1, ("demutm" - 400) / 800.0)) 
 
 Call this new grid fuzzy elev in the table of contents 
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2. Use the raster calculator on distance from airports (dist2airports) 
 


Con("dist2airports" < 800, 0, Con("dist2airports" > 2400, 1, ("dist2airports" - 800) 
/ 1600.0)) 


 
 Call this new grid fuzzy airport dist in the table of contents 


 
 
3. Use the raster calculator on distance from power (dist2power) 
 


Con("dist2power" > 4800, 0, Con("dist2power" < 1600, 1, ((4800 - "dist2power") / 
3200.0))) 
 
 Call this new grid fuzzy power dist in the table of contents 


 
 
4. Use the raster calculator on visibility (visibility) 
 


Con("visibility" < 4, 1, Con("visibility" > 12, 0, ((12 - "visibility") / 8.0))) 
 
 Call this new grid fuzzy visibility in the table of contents 


 
 
5. Use the raster calculator on areas that are west facing slopes (asp), southwest, or 


northwest. 
 


Con("asp" <= 202, 0, Con("asp" < 247, (("asp" - 202) / 45.5), Con("asp" < 292.5, 
1, Con("asp" < 337.5, ((337.5 - "asp") / 45), 0)))) 


 
 Call this new grid fuzzy aspect in the table of contents 


 
 
6. Now combine all of the grids using multiplication and conversion to integer making 


sure to include the conversion of the data to integer using the equation below.  If 
your grid names are different from not following exactly my renaming structure 
above don’t sweat it – just change accordingly to make it work.  Note that the result 
is usually expressed in a range from 0 to 1 but I included 100 to put the result in a 0 
to 100 range so that I could also keep the values integer which saves space. 


 
Int(("fuzzy aspect" * "fuzzy visibility" * "fuzzy power dist" * "fuzzy airport dist" * 
"fuzzy elev") * 100) 
 


 
7. I have decided to call mine fuzz-result.  You will use this grid again to answer some 


questions and make a map comparing it to the other suitability modeling 
approaches. 
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PART A QUESTIONS  
 
1.  Besides the boolean operator &, what is another method that could be used to find 
the suitable areas in Part B of this exercise?  Explain.  What would have happened to 
your map result from Part C and Part D if you combined all the scored criteria layers 
with the & operator? 
 
2.  How many of the cells from the boolean overlay from Part B of this exercise were 
suitable for windfarms?  What is the total area in acres?  What percentage of the study 
area is suitable with this method? 
 
3.  In Part C of this exercise how would the addition of all the final objective grids give 
us a different result than the multiplicative operator you were told to use?  Explain. 
 
4.  How many of the cells from the index overlay from Part C of this exercise were 
suitable for windfarms?  What is the total area in acres?  What percentage of the study 
area is suitable with this method?  
 
5.  Based on the papers that were provided for this topic, what part of the suitability 
model is missing from our analysis?  Explain. Also based on the assigned papers, what 
are some limitations with what we did? 
 
6.  How many of the cells from the fuzzy membership functions from Part D of this 
exercise were suitable for windfarms?  What is the total area in acres?  What 
percentage of the study area is suitable with this method?  
 
7.  Using the lecture notes from class as a guide, draw membership functions for the 
objectives we calculated in Part D of the exercise. You may find it easier to do them as 
graphs in Excel. 
 
8.  Using the final output grids from Part B, C, and D, display the maps all on one page 
using a legend for windfarm suitable areas as highly suitable, suitable, low suitability 
and not suitable.  Include any appropriate text on your map and be sure to explain how 
you made the decision on the levels of suitability.   
 
9.  Explain which of these techniques Boolean, Index Overlay, and Fuzzy logic would be 
best used if our wind power company was not going to receive any government 
subsidies and the decision for siting these windfarms had to be as good as possible 
while still being able to rank order sites.  
 
10.  Go to ArcMap Help and explain the fuzzy membership tool available in the 
software.   
 
11.  Answer the questions regarding the following readings for this topic. 
 
PAPER #1 (Eastman et al., 1995) 
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a) What is multicriteria evaluation? 
b) Why is it necessary to standardize criteria scores? 
c) Describe what a least risk solution is. 


 
PAPER #2 (Yoon, 1989) 


a) What is the purpose of this paper? 
b) What could be some possible sources of error when performing spatial 


map overlay? 
 
PAPER #3 (Veregin, 1995) 


a) Describe the relationship between the composite map accuracy and the 
number of data layers used as inputs in a model (Figure 7). 


 
 
12.  Go back and create an ArcMap model using Model Builder for the Fuzzy logic 
membership functions and final overlay model.  Also be sure to save your toolbox and 
all the input grids you will need (visibility, distance to airports, powerlines, aspect, 
elevation) because we will use this model next for sensitivity analysis.  
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Part B – Group Exercise 
 
This part of the lab assignment today requires you to work in groups of three to four 
students.  Also, come up with a group name.  
 
Using the criteria to find suitable areas to develop windfarms: 


 Degree of visibility 
 Elevation 
 Westerly facing slopes 
 Distance from airports 
 Distance from power networks  


 
I would like each group of three to four students to reach consensus on the preference 
weights that should be allocated to each of the criteria.  Work with each other to decide 
on weights using the point allocation method, and one of the ranking methods of your 
group’s choice.  After completing the tables below, work through the pairwise 
comparisons as a group on the back side of this document.  You will later calculate the 
weights from your pairwise comparison results on your own using EXCEL.   
 
Rating method: Point allocation 
 
WEIGHT CRITERIA 
 Degree of visibility 
 Elevation 
 Westerly facing slopes 
 Distance from airports 
 Distance from power networks 
 
 
Ranking method you chose:_______________ 
 
WEIGHT CRITERIA 
 Degree of visibility 
 Elevation 
 Westerly facing slopes 
 Distance from airports 
 Distance from power networks 
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PART B QUESTIONS 
 
Question 1 
You worked with other students to compute weights for the five criteria to be used for 
evaluating areas for windfarms.  You used the rating method (point allocation), a 
ranking method of your group’s choice and the also completed the pairwise comparison 
form.  Now I would like you to use the results from the pairwise comparison form to 
compute weights for each of the criteria.  I would like you to use Excel for the 
calculations.  Refer to the example used in lecture for help. 
 
 
Question 2 
Was the type of pairwise comparison test an abbreviated or full pairwise comparison?  
How do you know?  Were the pairwise comparison responses consistent within your 
group?  Explain how you could determine if they were or not consistent?   
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Question 3 
In the lab today each group will have to calculate weights using the pairwise comparison 
approach and when finished report the weights in a table written on the board. Once 
you have the weights from all the groups I would like you to determine if the weights 
from all the different groups should be averaged for one overall weight set – Show all 
work!  (Note: see the Strager and Rosenberger 2006 paper for guidance on the inter 
group preferences, ie stakeholders versus board members versus outside experts).  
Hint: the stat test Chi-Square will work fine. 
 


 
 
Question 4 
In the partB folder of the suit-modeling directory add the grid datasets into ArcMap for 
fuz-vis, fuz-airport, fuz-aspect, fuz-elev, and fuz-power.  These are the data layers 
representing the fuzzy utility scores from the previous part A.  They include fuzzy 
membership function grids for visibility, distance from airports, westerly facing slopes, 
elevation, and distance to power networks. 
 
I would like you to create suitability grids for each of the groups using the fuzzy criteria 
grids and the preference weights from each groups’ pairwise comparison results.  Use 
the Weighted Sum command in ArcToolbox to integrate the criteria and weights.  Find 
the top 15% of the score for each group and then determine if there is any common 
area that they share.   The locations that share the same top 15% will be the locations 
least affected by preference weights and therefore the most robust in our overall 
suitability result.  They have the most spatial consensus and will be the easiest to 
actually get a windfarm project to happen.  Make a map of just these areas and export 
the map as a jpg. 
 
Question 5 
Notice that in the PartB folder is a shapefile of the proposed windfarms called 
windfarms.shp.  Add this shapefile to ArcMap and compare your group’s weights to 
these windfarm locations.  Many of these windfarms have been permitted but not yet 
built.  Were the areas you found to be suitable for windfarms similar to where the 
permitted windfarms are located?  What do you feel were the driving factors for the 
locations of these permitted windfarms?  What criteria in our model may need to be 
reconsidered or the ranges for utility scores changed?   
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Exercise 4 - Using Modelbuilder to Create a Decision Support 
Tool 


  
 
 
Session Objectives:  At the conclusion of this session, you will be able to: 


 


 Use ArcGIS ModelBuilder to create a conceptual model  
 


 Calculate fields using logic with VBScript 


 
 


 Create a decision support map guiding conservation actions. 
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Material Created By:  Sean Fields (Dec 2012) 
 
Software:  ArcGIS 10, SP5 
 
Directory Path: D:\CSP7300\DST_Exercise 
 
GDB:  mt_bwd_wmd.gdg 
 
Imagery:  
 
MXDs: DST_Exercise.mxd 
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PART 1: Using Modelbuilder to create a polygon feature class representing density 
of nesting cover available to a breeding hen mallard in the Prairie Pothole Region of 
Montana 
 
The Prairie Pothole Region (PPR) of North America is the most important breeding area for 
upland nesting ducks on the continent, including mallard (Anas platyrhynchos).  Prior to an 
annual ground-based survey to collect data for habitat and population analysis, the 
following conceptual model was created to guide management actions to benefit breeding 
mallards in the PPR of Montana. Conceptually, waterfowl biologists agree that areas with 
high wetland and grassland densities have a greater potential to benefit breeding 
populations compared to areas with low grassland and wetland densities.  Using these two 
basic habitat preferences, we will create a model that identifies areas in the Bowdoin 
Wetland Management District for specific management actions. 
 
 
All data are located in D:\CSP7300\DST_Exercise, unless otherwise noted. 
 
 
STEP 1: Create a new model in ArcToolbox 
 
 Launch ArcMap and open DST_Exercise.mxd. 


 
 Familiarize yourself with the layers in the Table of Contents.  Use the View Item 


Description in the Data option in each of the layer properties to read the description. 
(Note: two object tables are located in the List By Source section of the Table of 
Contents) 


 
 Open ArcToolbox and add the CSP7300 toolbox created in the first ModelBuilder 


exercise.   Create a new model in the toolbox. 
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 Rename the model. Open the Model Properties dialog located in the Model menu at 
the top of the ModelBuilder interface.   Change the name to MallardDST (no spaces) 
and the label to Mallard DST 
 


                   
 


 
STEP  2:  Add geoprocessing tools to the model to reclassify the landcover and run a raster 
neighborhood analysis to identify areas of perennial nesting cover.  
 
 
 Drag the Reclass By Table tool (Spatial Analyst Tools → Reclass) into the 


ModelBuilder canvas.  Use the tool to reclassify the Bowdoin WMD ReGAP 
Landcover layer to a binary perennial nesting cover raster (i.e. 1 = nesting cover, 0 = 
non-nesting cover).  Set the tool parameters to match the one below.  Click OK. 
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 The simple model containing one geoprocessing tool should look similar to the one 
below. 
 


              
 


 
 Drag the Focal Statistics tool (Spatial Analyst Tools → Neighborhood) into the 


ModelBuilder canvas.  You will sum the total number of cells representing nesting cover 
in a neighborhood size around each grid cell that represents the home range of a 
breeding hen mallard (radius of 1810 m = circle area of 4 mi2). Set the tool parameters 
to match the ones below.  Set the Radius AFTER choosing Map as the units. Click OK. 
 


 







GIS Design II: Data Analysis and Model Building                                                                                    2012 
U.S. Fish and Wildlife Service                              National Conservation Training Center 


 


Conceptual Model Decision Support Tool                                                                                      6 


 
 The model should now look similar to the one below. 


 


  
 
 


 Drag the Times tool (Spatial Analyst Tools → Math) into the model. Set the parameters 
to match the ones below.  This will calculate the proportion of nesting cover within a 
home range of a breeding hen mallard. (Note:  The constant value of 0.00006884 is 
used here because there are a total of 14505 pixels in a neighborhood defined by a 
1810 meter radius.  To get the proportion of nesting cover around a given pixel, the 
pixel value must be divided by 14505 or multiplied by 0.00006894 (1/14505).  The 
Divide tool does not work for this step because the resulting raster is an integer type.  
We need a floating point raster type to store the decimal values.) 
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 The model should now look similar to the one below. 


 


 
 
 
STEP  3:  Add geoprocessing tools to the model to reclassify the percent nesting cover 
raster to categories and convert it to a polygon feature class. 
 
 
 Drag the Reclass By Table tool (Spatial Analyst Tools → Reclass) to reclassify the 


bwd_nesting_prop raster layer to a raster with aggregated nesting classes. Set the 
tool parameters to match the one below.  Click OK. 
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 Drag the Raster to Polygon tool (Conversion Tools → From Raster) to convert the 
bwd_nesting_reclass raster layer to a polygon feature class. Set the tool parameters 
to match the one below.  Click OK. 
 


 
 


 
 


 The model should now look like the one below.   Save the model. 
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 Run the model and review the results.  Symbolize bwd_nesting_classes_pl  with the 


bwd_nesting_classes_pl.lyr layer file (Hint: use the Import option in the symbology 
tab of the layer properties).  Compare the areas in the Bowdoin Wetland Management 
District with high densities of nesting cover to the original ReGAP Landcover.  Do the 
results make sense?  (NOTE:  5 minute model run time) 


 
 


 
 
STOP HERE 
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PART 2:  Calculate the density of prairie potholes in square mile sections  
 
 
STEP 1: Convert the wetland basin polygon layer to points  
 
 Add the Feature to Point tool (Data Management Tools → Features) to the Mallard 


DST model. This tool begins a new branch to the model.   
 
 Choose bwd_basins as the input features. 
 
 Name the output file bwd_basins_pt and save it in the mt_bwd_wmd geodatabase. 
 
 Choose the inside option (i.e. make sure it is checked) to ensure the points fall inside 


the wetland basin polygons.  Click OK. 
 


 
 


 
 
 
STEP 2: Create a spatial join to sum the number of wetlands in each section of the PLSS 
layer. 
 
 Add the Spatial Join tool (Analysis Tools → Overlay) to the model. 
 
 Choose Bowdoin WMD PLSS as the target feature.   
 
 Choose bwd_basins_pt as the join features. 


 
 Name the output feature class bwd_basins_plss_join and save it in the mt_bwd_wmd 


geodatabase. 
 
 Choose CONTAINS as the match option and keep the remaining defaults. Click OK. 
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STEP 3: Create a new field and and calculate the field using a VB script. 
 
 Add the Add Field tool (Data Management Tools → Fields) to the model.   
 
 Choose bwd_basins_plss_join as the input table.  Set the remaining tool parameters 


to match the one below. Click OK. 
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STEP 4: Calculate the new field to aggregated wetland basin counts using VBA field 
calculator.  (Note: An alternate to using the VBA code block would be to iteratively select 
records in the feature class and calculate them for each category.  Learning to use VB or 
Python scripting will save time and make you a more efficient spatial analyst.) 
 
 Add the Calculate Field tool (Data Management Tools → Fields) to the model.   


 
 Choose “bwd_basins_plss_join(2)” as the input table.   


 
 Set the field name to “wet_class_count”. 


 
 Type “wetclass” into the expression parameter. Do not use expression builder for this. 


 
 Set the expression type to be “VB” 


  
 Open the “calculate_fields_expression1.txt” text file in the exercise directory using 


notepad.  Copy and paste all of the text to the code block.  Review the code.  See if you 
can follow and understand the code logic.  The tool parameters should match the one 
below. 
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 The second part/branch of the Mallard DST model created in Part 2 above should 
look like the one below 
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PART 3:  Union the nesting cover density feature class with the wetland basin 
frequency feature class and symbolize the result to create a decision support tool. 
 
STEP 1: Union the feature classes together.   
 


 Drag the Union tool (Analysis Tools → Overlay) into the model.  Choose the 
“bwd_basins_plss_join(3)” layer and the “bwd_nesting_classes_pl” layer as the 
input features from the dropdown list.  Leave the Ranks fields blank. 


 
 Name the output feature class “bwd_decision_tool” in the mt_bwd_wmd.gdb 


geodatabase.  Keep the remaining default values and click OK.  The tool should look 
like the one below. 


 


             
  
STEP 2: Add a new field.   
 
 Add the Add Field tool (Data Management Tools → Fields) to the model.   
 
 Choose bwd_decision_tool as the input table.   


 
 Call the new field “action” .Set the remaining tool parameters to match the one below. 


Click OK. 
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STEP 3: Calculate the new field to desired conservation actions using VBA field calculator. 
 
 Add the Calculate Field tool (Data Management Tools → Fields) to the model.   


 
 Choose “bwd_decision_tool(2)” as the input table.   


 
 Set the new field name to “action”. 


 
 Type “con_action” in the expression parameter.  Do not use expression builder for 


this. 
 


 Set the expression type to be “VB” 
 


 Open the “calculate_fields_expression2.txt” text file in the exercise directory using 
notepad.  Copy and paste all of the text to the code block.  Review the code.  See if you 
can follow and understand the code logic.  The tool parameters should match the one 
below. 
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STEP 4: Run the model and review the results.   
 


 Save the model.  It should look similar to the one below (Note:  The model below 
was reorganized to fit on the page). 
 


 
 
 


 Run the model.  This will execute only the portion that was not run in Part 1. 
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 Add the results “bwd_decision_tool” to the map and symbolize using the 
bwd_decision_tool.lyr layer file located in the project directory. Use the Import 
option in the Symbology tab of the layer properties to import the symbology in the 
bwd_decision_tool.lyr file. 
 


 Your results should look like the one below 
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Exercise 5 – Hydrological and Watershed Analysis  
 
 
Session Objectives:  At the conclusion of this session, you will be able to: 


 


 Use ArcGIS to compute flow direction, flow accumulation grids, delineate 
watersheds, track overland flow across the landscape and calculate drainage 
areas. 
 


 Perform a watershed analysis to estimate stream flows, develop a surface moisture 
index, calculate stream curvature and delineate riparian areas. 
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Material Created By:  Mike Strager (Dec 2012) 
 
Revised: Eric Kelchlin (Dec 2012) 
 
Software:  ArcGIS 10, SP5 
 
Directory Path: D:\CSP7300\Exercise5\hydro-lab 
 
GDB:  all shapefiles 
 
Imagery: demfill (elevation), finaltif.tiff (aerial photo), lake_lynn_se.sid (topo 24k) 
 
MXDs: lab-exercise.mxd 
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Part A - Surface Hydrological Analysis 
 
In this part you will perform some common GIS hydrological analysis.  Using the topics 
presented in lecture, you will compute flow direction and flow accumulation grids, delineate 
watersheds, track overland flow across the landscape, and calculate drainage areas. 
 
All data are located in D:\CSP7300\Exercise5\hydro-lab, unless otherwise noted. 
 
1. Launch ArcMap and open the lab-exercise.mxd.   


2. Use the identify tool,  to select different locations to query the elevation at different 
points.  The value of the pixel is the elevation in meters. 


 
Computing Hydrologic Grids for Analysis 
 
For this part of the exercise, you will compute the flow direction and flow accumulation grids 
to perform hydrological modeling. 
 
1. Set you’re Workspace to Exercise5 in the Geoprocessing>Environment Settings. 


 


 
 


2. Using the ArcToolbox -> Spatial Analysis Tools -> Hydrology, select Flow Direction as 
shown below.  Name the grid FlowDir. 
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 You should see a flow direction grid, which helps us track the overland flow across 
the landscape. 


 
3. Next, compute the flow accumulation grid. 
 


 Select Flow Accumulation in the Hydrology Spatial Analysis menu of ArcToolbox. 
 


 Specify the FlowDir grid as the input flow, and save the file as flowacc. 
 


 
 


 This will take a few seconds to run and will create a flow accumulation grid like the 
one below. 
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The lighter colored areas are those with higher flow accumulation values or higher drainage 
areas.  If you use the identify tool you can query this grid for its values.   
 
Remember that the values in the flow accumulation grid tell you the number of cells that flow 
to that location.  If you multiply the number of cells by the cell size (9meters) it will give you 
the drainage area in meters squared. 
 
1. For example, zoom to area above Coopers Rock Lake as shown below. 
 


 
2. Next, turn on the Flow Accumulation grid in the table of contents to see the accumulated 


cell values. 
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If you select one of the white cells with the identify button, it will tell you the number of cells 
that flow to that point.  In my example, I clicked on the white grid cell and found a cell value 
of 283,192.   
 
If I wanted to convert this value to drainage area, I would multiply it by 9 (each cell is 3 by 3 
meters) to get the drainage area in meters squared.  And if I wanted to convert it to acres I 
would multiply it by 0.00024718.  The work is shown below 
 
Flow Accumulation pixel value = 283,192 cells 
 
Drainage area in meters squared  = 283,192 * 9 
     = 2,548,728 meters squared 
 
Drainage area in acres   = 2,548,728 * 0.00024718 
     = 629 acres 
 
Using the method just described above, calculate the drainage area for the right fork of 
Glade run at the location shown below. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
TIP: there is a calculator available at START button -> All Programs -> Accessories -> 
Calculator. 
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Intermittent streams, stream orders and watersheds, 
 
For this part of the exercise, you will delineate potential intermittent stream paths from the 
drainage area grid.   
 
1. Select all the flow accumulation cells that have a minimum stream drainage of 80 acres 


and create a new grid using the Raster Calculator. 
 


Remember that the flow accumulation grid starts at a ridgetop with 0 cells flowing into it 
and picks up drainage area as it goes downstream.  You need to select the stream 
drainages that are 80 acres or larger (Based on USGS estimates for intermittent streams 
in this part of the Mid-Atlantic Highlands. 
 
 Determine the correct flow accumulation value to query that corresponds to 80 acres 


or larger.  Remember that the cell size is 3 meters by 3 meters.  Hint: 1 acre = 4046.9 
meters squared. 


 
2. Once you have created the new stream grid, run the Hydrology - > Stream Link 


command to create a unique numbering system for each stream segment.  After it runs 
you may have to make your grid symbology unique values to see each segment. 
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3. Stream order is also found in the Hydrology menu list and allows you to choose between 
strahler and shreve orders.  Run it as shown below even though your stream link output 
grid may be named slightly differently than mine.   


 


 
 
 
4. Determine how many first, second and third or higher order streams are present in this 


study area. 
 
5. Next, use the Watershed tool to delineate watersheds for each of the stream segments.  


Be sure you put the stream link grid for the feature pour point data.  This will assure you 
of having one watershed for each stream segment. 
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6. Change the Watershed symbology to unique values and set the transparency to 50% to 
see the topomap 24K in the background. 


 


 
 


7. Run the Flow Length command in the Hydrology tools for our study area in both the up 
and downstream directions.  Try to interpret the results.    


 


 
 
 


8. Using the zonal statistics command on the spatial analyst toolbar, find the elevation min, 
max, for each of the stream segments.  HINT: you will first have to run the Stream Link 
command to create a unique identifier for each stream segment defined junction to 
junction. 
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9. Find the maximum flow length cell in this study area.  What is the value of this cell?  
What does it mean? 


 
 
Part B – Watershed Analysis 
 
This Part covers advanced watershed analysis.  It covers topics on stream flow estimation, 
developing a surface moisture index, curvature analysis, finding potentially affected 
streams, and riparian area delineation. 
 
Stream Flow Estimation 
 
As discussed in lecture, we can estimate stream flow based on a ratio method using a 
known stream gauge and a drainage area relationship.  If you saved your work from the last 
exercise you will have the flow direction, flow accumulation and raster stream grids already 
completed for this exercise.   
 
1. We will apply a stream flow relationship for the upper right fork of the Johnson Hollow 


Stream segment.  You can find this stream using the topomap 1:24K layer in this lab-
exercise.mxd layer file. 


 
 If you don’t have the raster stream grids from last exercise, find the 80 acre drainage 


from the flow accumulation grid which is 323,748 meters squared or 35,972 flow 
accumulation units since our flow accumulation grid is 3m by 3m in size. 


 


 
 
2. Assume that there is a USGS gauging station at the bottom of Johnson Hollow as it 


leaves our mapped study area extent.  The flow at this gauge reads 62 cfs during 
average 30 day September flow which is the lowest monthly stream flow in this part of 
the country.   
 
 If this stream will be subject to Marcellus gas well drilling, what is the average stream 


flow for the upper right fork? 
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3. Determine the drainage area and stream flow for the upper right fork of this Johnson 
Hollow stream reach.  Show all your work. 


 
 
 
 
 
4. Do you feel this calculation with these numbers is appropriate?  Why or why not? 
 
 
Developing a Moisture Index 
 
The moisture index assumes that the relative moisture in a particular area (in our case a 
grid cell) primarily depends on two factors; how much water is flowing into the area and how 
fast the water can flow out of the area.  First the catchment area is determined for each cell 
(flowaccumulation command).  This is the amount of upslope area (or the number of cells) 
that contributes water to the cell.  The slope at the cell then determines how fast the water 
can run off the cell.  The index combines these two indices with the formula:   
 
   Ln [(catchment area + 1) / (slope + 1)].   
 
This is a relative moisture index so the resulting numbers do not have units, yet the higher, 
more positive, numbers are wetter and the lower, more negative, numbers are drier. 
 
You already have flow accumulation for this study area and just need to calculate slope. 
 
1. Use the Spatial Analyst Tools -> Surface -> Slope.  Specify the input raster to be the 


elevation surface and the measurement can be degrees or slope. 
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 Next, combine the flow accumulation and slope grid output into the raster calculator 
with the equation noted above.  For example: 


 
Ln(("flowacc" + 1) / ("slope" + 1)) 


 
2. This output may be very difficult to understand with the default legend values and colors.  


My suggestion is to redo the legend so that you have positive values in two ranges of dry 
and driest and two ranges of negative values as moist and wet as shown below. 


 


 
 
 
3. Find on the topoquad the area around Harris Lake. Examine the moisture values.  Do 


these values make sense?  Why or why not?  
 


4. Do you feel this 3m DEM is the most appropriate scale of data to run a moisture analysis 
upon?  Why or why not? 


 
 
Curvature Analysis 
 
The curvature command in ArcGIS calculates the curvature of a raster surface, optionally 
including profile and plan curvature (ESRI, 2010).  The following description is from the 
ArcGIS help system. 
 
The Curvature tool calculates the second derivative value of the input surface on a cell-by-
cell basis. 
 
For each cell, a fourth-order polynomial of the form: 
 
 Z = Ax²y² + Bx²y + Cxy² + Dx² + Ey² + Fxy + Gx + Hy + I 
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is fit to a surface composed of a 3x3 window. The coefficients a, b, c, and so on, are 
calculated from this surface.  
 
The relationships between the coefficients and the nine values of elevation for every cell 
numbered as shown on the diagram are as follows: 
 


 
 


 
From an applied viewpoint, the output of the tool can be used to describe the physical 
characteristics of a drainage basin in an effort to understand erosion and runoff processes. 
The slope affects the overall rate of movement downslope.   Aspect defines the direction of 
flow.  The profile curvature affects the acceleration and deceleration of flow and, therefore, 
influences erosion and deposition.  The planform curvature influences convergence and 
divergence of flow. 
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Displaying contours over a raster may help with understanding and interpreting the data 
resulting from the execution of the Curvature tool. An example of the process follows: 
 
1. Calculate the curvature of this study area using the curvature tool found in the Spatial 


Analyst Tools -> Surface -> Curvature. 
 


 
 
The primary output is the curvature of the surface on a cell-by-cell basis, as fitted through 
that cell and its eight surrounding neighbors. Curvature is the second derivative of the 
surface, or the slope-of-the-slope. 
 
A positive curvature indicates the surface is upwardly convex at that cell. A negative 
curvature indicates the surface is upwardly concave at that cell. A value of 0 indicates the 
surface is flat. 
 
2. Make an output map from curvature that shows three legend values.  One for convex 


areas, one for flat areas and one for concave areas. 
 


3. How could the results from the moisture grid and the curvature grid be used together to 
gain additional surface characterization? 
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Finding Potentially Affected Streams 
 
The goal of this GIS technique is to find which streams and where in the streams potential 
runoff will enter.  We can do this in a raster framework using a series of commands that are 
outlined in the steps below.   
 
1. The first thing we need to do is map some potential sources of non-point source runoff. 


We will use the aerial photograph as a base to digitize some potential sources.  To do 
this we need to create a new polygon shapefile. 


 
 Right-click on the Exercise5 folder in ArcCatalog and select New>Shapefile.  Name 


the shapefile sources and give it a NAD83, UTM17 Coordinate system.  The new 
shapefile should be added to your display. 


 
 Make the aerial photo layer visible and start an editing session on the sources 


shapefile.  Pan to an area and digitize surface disturbance such as the clear cut I 
found that is shown below. 


 
 After digitizing about 4 or 5 polygons of potential runoff sources give the polygons to 


a value of 1000 in the Id field.  This will be used as a weight grid in our flow 
accumulation command to follow.  Stop editing and save edits. 
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2. Now, in the Conversion Tools -> To Raster -> Polygon to Raster, specify the sources 
shapefile as the input and the ID field in which to create the grid values.  The output cells 
size should be the same as the other grids in our study area which is 3. 


 


 
 
You should now have an output grid in your table of contents that is a raster representation 
of the digitized polygons.  We will now use it as the potential source of our overland flow 
runoff to determine which streams and where in the streams the runoff is entering. 
 
3. Specify our already completed flow direction and weight grid as inputs into the flow 


accumulation command.  This flow accumulation will be different from before since it is 
now weighted with the potential pollution sources. 
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4. From this newly created weighted flow accumulation grid, select out only the values 
greater than 0 using the Raster Calculator. 


 
5. Change the legend colors so that 0 is clear and values of 1 are red.  Now you can see 


the overland flow path from the pollution sources and the streams and where in the 
stream they would enter. 


 


 
 


 
6. What is being assumed with the mapping of the overland flow potentially affected 


streams approach? 
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Riparian Area Delineation 
 
The goal of the riparian area delineation is to use the natural slope next to a stream 
segment to help define the area instead of a general set buffer width that is used in more 
traditional work.  The two main inputs to this method are the slope and the location of the 
mapped stream segments.  It is helpful if the streams are raster based and delineated from 
the same elevation surface used for the slope grid.  The “cost” when slope is used 
approximates a level of impedance for water to extend.  Even though we are using just 
slope as the major “cost” grid it could be enhanced with other surface factors such as soils 
and vegetation to help better define the riparian area.   
 
From the earlier steps you should still have the slope grid and a raster grid of just the stream 
locations.   
 
IMPORTANT: if you are using a raster representation of the streams, then the cells need to 
be 1 or any nonzero value for where the streams are and NODATA for the background or 
non-stream locations. 
 
1. To change the values of the raster cells select Spatial Analyst Tools -> Reclass -> 


Reclassify 
 


 Make sure to change the background 0 values to NODATA 
 


 
 


 Now we are ready to use this reclassed stream grid (reclass_strm is what I called 
mine) in the cost distance command with the slope grid. 
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2. To create a cost distance grid select Spatial Analyst Tools -> Distance -> Cost Distance  
 


 Enter the input raster and cost raster as shown below 
 


 
 
3. The results should look similar to the one below.  Note that the values represent 


impedance values or how difficult it is to move from the source locations (the raster 
stream grid) to areas away from it.   
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To create a grid layer of this area that represents the riparian area, select a value from the 
cost distance output.  I have used field observed locations or aerial imagery to help define 
the value to use.   
 
1. For this example, use the Raster Calculator to select all cells that are less than 2,000 
 
2. Make the output transparent to see how it overlays with the imagery or elevation data.   
 


  
 
Again, this is a proxy for riparian area but has been shown to better approximate the natural 
conditions of the terrain than a set buffer distance. 
 
3. Besides slope, what other factors could/should be integrated with the cost raster in this 


cost distance command to better delineate a riparian area. 
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Exercise 6 – Using Modelbuilder to Automate Processes: 
Advanced Techniques with Iterators. 


  
 
 
Session Objectives:  At the conclusion of this session, you will be able to: 


 


 Use iterators in ArcGIS ModelBuilder  
 


 Use nested/sub models in ModelBuilder 


 
 


 Use in-line variable substitution  in ModelBuilder 
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Material Created By:  Sean Fields (Dec 2012) 
 
Software:  ArcGIS 10, SP5 
 
Directory Path: D:\CSP7300\FER_Exercise 
 
GDB:  brwca_project.gdb 
 
Imagery:  
 
MXDs: FER_Exercise.mxd 
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PART 1: Using Modelbuilder iterators to run processes repeatedly 


Iteration, often referred to as looping, means to repeat a process over and over with some 
degree of automation. Iteration is very important because automating repetitive tasks 
reduces the time and effort required to perform the tasks. With iteration in ModelBuilder, a 
process can be executed over and over using different settings or data in each iteration. 
ModelBuilder also provides flexibility in iteration, as an entire model or simply a single tool 
or process can be executed repeatedly. 


All data are located in D:\CSP7300\FER_Exercise, unless otherwise noted. 
 
STEP 1: Create two new models in ArcToolbox 
 
 Launch ArcMap and open FER_Exercise.mxd. 


 
 Familiarize yourself with the layers in the Table of Contents.  Use the View Item 


Description in the Data option in each of the layer properties to read the description.  
 
 Open ArcToolbox and add the CSP7300 toolbox created in the first ModelBuilder 


exercise.   Create a new model in the toolbox. 
 


 


 
 
 
 
 Rename the model. Open the Model Properties dialog located in the Model menu at 


the top of the ModelBuilder interface.   Change the label to “FER Data Prep Model” 
and the name to “FERDataPrepModel”.  Add a description similar to the one below.   
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 Create a second new model in the CSP7300 toolbox labeled “FER Landcover Prep 


Submodel”.   This model will contain geoprocessing tools to create different layers for 
each landcover class. 


 
STEP  2:  Add geoprocessing tools to the FER Data Prep Model model to reclassify the 
landcover  
 
 Drag the Reclassify tool (Spatial Analyst Tools → Reclass) into the FER Data Prep 


Model to reclassify the brwca_regap landcover layer to generalized classes  
(i.e. change all forest classes [41 = deciduous forest, 42 = evergreen forest, 43 = mixed 
forest]  to a single forest class [40 = forest]) 
 
 Set the tool parameters to match the one below.  See the full table on the next page for 
all class values.  Click OK. 
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 The simple model containing one geoprocessing tool should look similar to the one 


below.  
 


              
 
 
 Run the model and add the results to ArcMap.  Save and close the model.   
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STEP  3:  Add a multi-value iterator to the FER Landcover Prep Submodel to run 
geoprocessing tools in an automated mode. 


 
 Open the FER Landcover Prep Submodel for editing.  Choose 


Insert→Iterators→Multivalue from the ModelBuilder menu. 
 


 
 
 We are going to add a variable to the model to hold the multivalues for the iterator.  This 


keeps the model organized.  Right-click in the ModelBuilder canvas and select Create 
Variable.  Select Any Value and check the Multivalue box in the dialog. Click OK 
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 Use the Connect tool (located on the ModelBuilder Standard toolbar       ) to connect the 
multiple value variable to the Multivalue Iterator.  Choose Input Value when prompted 
after connecting the two together. 


 
 Double click the multiple value variable and add the following landcover codes to the list 


by entering them individually in the Multiple Value textbox. Click OK. 
 


 
 
 The model containing the multivalue iterator should look like the one below 
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STEP  4:  Add landcover geoprocessing tools to the FER Landcover Prep Submodel and 
use inline variable substitution in the tool parameters. 
 
 Drag the Con tool (Spatial Analyst Tools → Conditional) into the FER Landcover Prep 


Submodel.  The tool performs a conditional if/else evaluation on each of the input cells 
of an input raster.   
 


 We will be using inline variable substitution in two of the tool parameters; Expression 
and Output Raster.  Any variable in the model can be used as a variable substitute by 
enclosing the variable name in percent symbols (%variable name%).  The entire model 
will run for each value in the iterator, and the %Value% will represent the current value.  
In the tool parameters below the Expression and Ouput Raster each contain the inline 
variable %Value% which will change in each iteration, resulting in different expressions 
and different output raster names.   


 
 Set the tool parameters to match the ones below.  Be sure to type the Expression with 


the in-line variable instead of using the Expression Builder.  The iteration and in-line 
variable substitution will result in 8 final binary rasters named brwca_lndcvr_10, 
brwca_lndcvr_20, brwca_lndcvr30, etc. 


 


 
 


 Drag the Focal Statistic tool (Spatial Analyst Tools → Neighborhood) into the FER 
Landcover Prep Submodel.  Set the tool parameters to match the ones below.  Be sure 
to use the inline variable substitution for the Input and Output raster. (Note: change the 
Units under Neighboorhood Settings to Map before typing in the Radius) 
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 Your model should look similar to the one below. 
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 Drag the Times tool (Spatial Analyst Tools → Math) into the FER Landcover Prep 


Submodel. Set the tool parameters to match the ones below.  The constant value of 
0.000199 is used because there are 5025 cells in a neighborhood defined by a 1200 
m radius (1/5025 = 0.000199). Click OK.  Save the model but keep it open. 


 


 
 
 
 
STOP HERE 
 
 


 
 
 


 
 
PART 2: Integrating a model within a model: using nested models in Modelbuilder.   
 
Like all other geoprocessing tools, model tools can be executed from a dialog box, through 
Python scripting, or added and run in another model.  The idea of adding and running one 
model tool within another model is sometimes referred to as a submodel, nested model, or 
model within a model. There are two main reasons for using this type of model hierarchy: to 
simplify a large, complex model or allow for more advanced use of model iterators. When a 
workflow requires model iteration, the specific tools or processes that need to be run more 
than once must be separated from those tools or processes that only need to be run once 
per workflow. In this situation, all tools that need to run multiple times should be placed in 
one model with a model iterator and used as a submodel. The tools that only need to be 
run once should be placed in the main model, which calls the iterating submodel. 
 
STEP  1:  Prepare the FER Landcover Prep Submodel for nesting in another model 
 
 
 Select and delete the brwca_lndcvr input data to the Con tool in the FER Landcover 


Prep Submodel.  Most of the model tools after the Con tool will become empty with no 
color.   
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 Right-click on the Con tool and choose Make Variable → From Parameter → Input 
Conditional Raster.   


 


 
 


 Next, right-click on the Input Conditional Raster variable and choose Model 
Parameter.  The letter “P” is now next to the model graphic indicating it is a model 
parameter.  Setting this as a model parameter will allow us to use the FER Landcover 
Prep Submodel  as a nested model in the main FER Data Prep Model.  The sub 
model should look similar to the one below.  Save the model and close it. 
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 Open the FER Data Prep Model for editing.  Drag the FER Landcover Prep 


Submodel into the model.   Connect the Reclassify tool output, brwca_lndcvr, to the 
FER Landcover Prep Submodel and choose Input Condition Raster when prompted.  
The FER Data Prep Model should now look like the one below. 
 


 
 
STEP  2:  Finalize the FER Data Prep Model 


 
 One more tool needs to be added to the FER Data Prep Model.  Drag the Focal 


Statistics tool (Spatial Analyst Tools → Neighborhood) into the model.  The average 
terrain roughness in a 1200m neighborhood around each pixel will be calculated.  
 


 Set the Input raster is the brwca_rough raster located in the brwca_project.gdb 
geodatabase 


 
 Set the Output raster name as rough12000 in the brwca_project.gdb 


geodatabase.  
 


 Set the other tool parameters to match the ones below.  Click OK. 
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 The final model should look like the one below.  Validate and run the entire model.  (15 


minute run time) 
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STOP HERE 
 
 
 
STEP  2:  Data clean up. 
 
Using ArcCatalog, rename each of the final rasters created in the model to match the 
names below. 
 
brwca_lndcvr_10_prop → water1200 
brwca_lndcvr_20_prop → urban1200  
brwca_lndcvr_30_prop → barren1200 
brwca_lndcvr_40_prop → forest1200 
brwca_lndcvr_50_prop → shrub1200 
brwca_lndcvr_70_prop → grass1200 
brwca_lndcvr_81_prop → hay1200 
brwca_lndcvr_82_prop → crop1200 
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Exercise 7 – Modeling Resource Selection and Creating a 
Predictive Map  


 
 
Session Objectives:  At the conclusion of this session, you will be able to: 


 


 Use ArcGIS to create used and available resource variables for data analysis in R 
statistical software. 
 


 Use a mixed-effects logistic regression approach in R to estimate resource 
selection functions. 


 


 Create a raster predictive map from estimated resource selection functions. 
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Material Created By:  Ryan Long  (June 2012) 
 
Modified: Eric Kelchlin (Dec 2012) 
 
Software:  ArcGIS 10, SP5 
 
Directory Path: D:\CSP7300\MELR_Exercise 
 
GDB:  MELR_Data.gdb 
 
Imagery:  
 
MXDs: MELR.mxd 
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PART 1: Modeling Resource Selection by Mule Deer Using Mixed-Effects Logistic 
Regression 
 
All data are located in D:\CSP7300\MELR_Exercise, unless otherwise noted. 
 
STEP 1: Extract Values to Points 
 
 Launch ArcMap and open the MELR.mxd. 


 
 Use the Extract Multi Values to Points Tool (Spatial Analyst Tools → Extraction) to 


attach values from each of the 3 raster data sets to the deer_points feature class. 
 


 
 


 Use the Spatial Join Tool (Analysis Tools → Overlay) to attach values from the 
habitat_type layer to the deer_points.   
 


 Output the new feature class in the Deer_Data feature dataset within the MELR_Data 
geodatabase.  Name the feature class “used_points”. 
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STEP  2:  Create a new field, calculate values and data clean-up 
 
 Right click on the used_points feature class and open the attribute table.  Click on the 


Table Options button  at the top left of the attribute table.   Select Add a new field 
and name it Used.  Keep it as a Short Integer. 


 
 Right-click on the Used field header and populate all the cells with a value of 1 using the 


field calculator.   
 


 
 Delete the Join_Count and Target_FID fields to clean things up a bit. 


 
 


 Sort the roads field.   Notice that we have some spurious data that have negative 
values.  Not all the raster layers covered the study area. You could find a nearest 
neighbor value and populate the cells, but for time’s sake, just delete these three 
records and move on.   


 
 
 Select all the records where roads are < 0 using the Select By Attributes dialog under 


Table Options. 
 


 Delete the spurious records using the Delete Rows Tool (Data management Tools 
Table), or start an editing session first, then select the records and tap the Delete Key.   
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STEP 3: Create random locations to serve as the necessary index to habitat availability 
 
 Data Management Tools → Feature Class → Create Random Points. 
 
 Name the output file “Available” and output it to the Deer_Data feature dataset in the 


MELR_Data geodatabase. 
 


 Choose “Study_Area” as the constraining feature class. 
 


 We will use 1 available location for every used location, so enter 38,214 as the number 
of points to create.  Leave everything else the same and hit OK. 
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STEP 4: Extract Values to Points and data management (Tip: Read all of step 4 before 
proceeding). 
 
 Repeat STEP 1-2 above and extract values from the 3 raster data sets and the 


Habitat_Type feature class.  However, DO NOT delete the spurious data yet! 
 
 Name the new feature class available_points during the spatial join process. 


 
 
 View the attribute table and delete the CID, Join_Count and Target_FID fields.  Use 


Xtools Pro to delete multiple fields at once (Table OperationsMultiDelete Fields). 
 


 
 Add a new short integer field and name it Used.  Use the Field Calculator to assign a 


value of 0 to every cell in the field. 
 


 Click on Table Options button  and add a new short integer field.  Name the field 
“RADIO”.  Your table should look like this one below. 


 


 
 


 
 


STEP 5: Merge the used and available feature classes 
 
 Click on the Geoprocessing tab on the main menu and select Merge. 
 
 Select used_points and available_points as your input files, name the output file 


Model_Data, and save as a feature class in the Deer_Data feature dataset in the 
MELR_Data geodatabase. 


 
 Delete the Date, Month, Day, Year, Time, Time2, X, and Y Fields.  You can do this in 


the Merge dialog before you hit the OK button. 
 


 







GIS Design II: Data Analysis and Model Building                                                                                    2012 
U.S. Fish and Wildlife Service                              National Conservation Training Center 


 


Mixed-Effects Logistic Regression                                                                                      7 


 
 


STEP 6: Export the data and finalize the model data set in Excel. 
 
 Export the tabular data as a dbf file in the MELR_Exercise folder.  Name it Model_Data.   


 
 Open the Model_Data.dbf file in Excel.  The “RADIO” values for the available points 


are currently 0 because we didn’t assign any values for that field yet.   
 


 What we need to do is assign 1 of those points to each used point for each deer.  To do 
this, simply copy the values in the “RADIO” field for the used (used = 1) points and 
paste them in the “RADIO” field for the available (used = 0) points. 


 
 Next, delete the negative values that resulted from the extraction process, where the 


layers did not cover the available points.  Sort the dataset first by roads and then by 
elevation, and delete rows where the value for any of those variables are negative.  You 
should end up with roughly 76,346 rows of data, including column headings. 


 
 Save the file as a comma delimited (CSV) file in the same folder.  Name it 


MELR_Data.csv. 
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STEP 7: Run the model. 
 
 Launch R and open the MY_Script.R file (File>Open Script). 


 
 The first line in the script may need to be altered to reflect the exact location of your 


.csv data set. 
 


 Everything else should remain the same, provided that the field headings in your data 
set match those in the script exactly (case matters!). 


 
 


 
 
 
STEP 8: Evaluate the model. 
 
We will do most of this together, but some initial questions to think about are: 


 
 How are the parameter estimates from the model interpreted?  What do they tell us 


about resource selection by mule deer? 
 


 What spatial and temporal scale are inferences from this model limited to? 
 


 What other models might we want to evaluate? 
  







GIS Design II: Data Analysis and Model Building                                                                                    2012 
U.S. Fish and Wildlife Service                              National Conservation Training Center 


 


Mixed-Effects Logistic Regression                                                                                      9 


PART II: Creating a Predictive Map from a Resource Selection Function 
 
STEP 1: Create a point grid that covers the study area. 
 
There’s more than one way to do this, but I’m going to show you how to create a uniform 
grid of points across the study area.  The size of the grid depends on your GIS layers 
involved in the analysis.  The habitat layer was extracted from a 30 meter pixel raster, but 
let’s just use 50 meters to save time. 
 


 First, create a fishnet (Data Management Tools  Feature Class  Create Fishnet) 
with a grid size of 50 meters square.   Name it grid_50m.  See the example below. 
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 Two layers will be created, one point layer (grid_50m_label), and the other a polygon 
(grid_50m).  The point layer is really all we need for this exercise. 


 
 Next, perform a Select by Location query to select only those points from the 


grid_50m_label layer that are completely within the study_area layer.   
 


 Export the selected data as a feature class in our geodatabase.  Name it 
grid_points.  Remove the other grid layers from the Table of Contents. 
 


 
 
STEP 2: Extract the values of each underlying layer (elevation, slope, roads, and 
habitat_type), add XY coordinates, and export to a dBase file. 
 


 For raster layers use: Spatial Analyst Tools → Extraction → Extract Multi Values to 
Points. 
 


 For vector layers use: Analysis Tools → Overlay → Spatial Join.  You will need to 
create a new feature class.  Name it grid_points_data. 
 


 To add XY coordinates: Data Management Tools → Features → Add XY 
Coordinates 
 


 Delete needless and erroneous data.  Open the grid_points_data attribute table.  
Delete the Join_Count and TARGET_FID fields.  Perform a select by attribute query 
and select all records where the roads are >= 0 to remove cells with no real values 
for the raster datasets.   You will have about 30520 records selected. 
 
 


 
 


 Export the selected records and save the data as a dBase file in the MELR_Exercise 
folder.    
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STEP 3: Calculate predicted Resource Suitability Function (RSF) values in Excel. 
 


 Open the dBase file in Excel.  Add a new column in the table for each categorical 
variable, which in our case is habitat_type.  The value of each of these new 
variables should be coded as 1 if that variable is present and 0 if it is not present.  
The easiest way to accomplish this is with an “If Then” equation in Excel.  See the 
screen shot below. 
 


 
 
 


 Add another new column, name it Predicted, and calculate the predicted RSF 
values using the appropriate equation, where the β values are the parameter 
estimates from your model and the X values are the values of each of your 
respective predictor variables. 
 


For RSFs based on any form of logistic regression and a use/available design: 
Predicted Value = EXP(β1X1 + β2X2…. ΒpXp).   
 
For an RSFs based on any kind of linear model (i.e., Sawyer et al. approach or 
RUF approach): Predicted Value = β0 + β1X1 + β2X2…. ΒpXp). 


 
 Save the table as an Excel file and close it. 
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STEP 4:  Create the predictive map in ArcGIS 
 


 Launch ArcCatalog from the desktop.  Find your Excel file and right-click on the 
appropriate sheet.  Select  Create Feature Class > From XY Table. 


 
 Choose the appropriate X and Y fields, as well as the appropriate coordinate system 


for your data, and save as a feature class in the geodatabase.  Name the new 
feature class predicted_points. 
 


 Close ArcCatalog and add the predicted_points feature class to your ArcMap 
document.  Remove any other point layers from the Table of Contents.   
 


 Convert the feature class to a raster-based predictive map using the appropriate 
conversion tool (Conversion Tools → To Raster → Point to Raster. 
 


 Select your point file as the Input Feature, your predicted values as the Value field, 
and whatever cell size you want (generally should match the resolution of your 
underlying habitat layers).  For this example, let’s use 50. 
 


 
 
 


 The resulting raster is your predictive map, and you can classify it, alter how it’s 
displayed, etc. by right-clicking on it, selecting Properties, and then opening the 
Symbology tab (see screen shot on next page). 
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Exercise 8 – Modeling Relative Abundance using Modelbuilder 
with R 


 
 
Session Objectives:  At the conclusion of this session, you will be able to: 


 


 Use ModelBuilder to create resource variables for data analysis in R statistical 
software. 
 


 Use a fixed-effects regression approach in R to estimate relative abundance 
 


 Create a raster predictive map from estimated generalized linear model 
coefficients. 
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Material Created By:  Sean Fields (Dec 2012) 
 
Software:  ArcGIS 10, SP5 
 
Directory Path: D:\CSP7300\FER_Exercise 
 
GDB:  brwca_project.gdb 
 
Imagery:  
 
MXDs: FER_Exercise.mxd 
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PART 1: Modeling Relative Abundance for Sage Thrasher Using Fixed-Effects 
Regression Analysis for Count Data 
 
All data are located in D:\CSP7300\FER_Exercise, unless otherwise noted. 
 
STEP 1: Create a new model in the CSP7301 toolbox and add geoprocessing tools to 
measure the proportion of landcover classes in a 1200 meter landscape around all BBS 
routes run in 2000. 
 
 Launch ArcMap and open a new document. 


 
 The landcover rasters created in the last ModelBuilder exercise (FER Data Prep 


Exercise) will be used in this exercise along with additional rasters that are already 
processed.  We will use those rasters with geoprocessing tools to create a database file 
to load into R for modeling. 
 


 Add the following raster layers from the brwca_project.gdb in the project directory to 
ArcMap.  


 
water1200 – the proportion of water/wetlands in a 1200m landscape 
urban1200 – the proportion of urban in a 1200m landscape 
grass1200 – the proportion of grass in a 1200m landscape 
forest1200 – the proportion of forest in a 1200m landscape 
shrub1200 – the proportion of shrub in a 1200m landscape 
crop1200 – the proportion of crop in a 1200m landscape 
patch1200 – the number of habitat patches in a 1200m landscape 
rough1200 – the mean terrain roughness in a 1200m landscape 
brwca_utmx – utm easting 
brwca_utmy – utm northing 
brwca_dem – elevation 
 


 Add the bbs_stops_2000 point feature class to the ArcMap document. 
 


 Add the bbs_sath_observations_2000 object table to the ArcMap document.  The 
table contains the observations for sage thrasher (SATH) for each BBS stop in the year 
2000 in the project area. 


 
 Open ArcToolbox.  Add the CSP7301 toolbox created in the first ModelBuilder exercise.  


Add a new model to the toolbox and label the model FER Covariates Model. 
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 Start editing the FER Covariates Model.  Drag the Join Field tool (Data Management 


Tools → Joins) into the model.  Join the bbs_sath_observations_2000 table (Join 
Table) to the bbs_stops_2000 feature class (Input Table) using “routestop” as the join 
field in both tables.  Only include the SATH field in the list of join fields.  Click OK. 
 


 
 
 


 
  Drag the Extract Multi Values to Points Tool (Spatial Analyst Tools → Extraction) into 


the model.   
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 Right-click on the Extract Multi Values to Points tool in the model and select Make 
Variable→From Parameter→Input Rasters. This will keep the model organized when 
adding several input rasters to the tool. 


 


 
 


  Double-click the Input Rasters parameter variable and add each of the 11 rasters to 
the list. Click OK.  The model will look similar to the one below. 
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 Double-click the Extract Multi Values to Points tool and specify the bbs_stops_2000 


as the input point feature class.  Your tool parameters should match the ones below.  
Click OK. 


 
 


 
 


 Drag the Copy Rows tool (Data Management Tools → Table) into your model and 
connect it to the output from the Extract Multi Values to Points tool from the previous 
step.  Use the output from the Extract Multi Values to Points tool as the Input Rows 
for the Copy Rows tool when prompted. 
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 Save the model.  Your model should look similar to the one below 
 


 
 
 
 Run the model and open the sath_model_variables.dbf to view the variables.   
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STEP 2: Run the model in R 
 
 Launch R and open the SATH_Script.R file (File>Open Script). 


 
 The first line in the script may need to be altered to reflect the exact location of your 


sath_model_variables.dbf data set. 
 


 Everything else should remain the same, provided that the field headings in your data 
set match those in the script exactly (case matters!). 


 
 


 
 


 Run the script and review the parameters estimates. 
 
 
We will do most of this together, but some initial questions to think about are: 


 
 How are the parameter estimates from the model interpreted?  What do they tell us 


about resource selection by sage thrashers? 
 


 What spatial and temporal scale are inferences from this model limited to? 
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PART II: Creating A Predictive Map using Regression Coefficients in R 
 
STEP 1: Use Map Algebra to apply the model coefficients in R to the rasters in ArcMap 
 


 Open the Raster Calculator tool (Spatial Analyst Tools → Map Algebra).  Use the 
Map Algebra expression builder to help build the following equation into the Map 
Algebra expression box.  The syntax must be exact.  
 
Exp( 4.426 + (0.000003198 * "brwca_utmy") + (0.00001299 *   "brwca_utmx") - 
(0.00341 * "brwca_dem") - (5.361 *  "urban1200") + (2.594  *  "grass1200") + (3.155 
*  "water1200") + (4.233 * "crop1200")  + (3.904 * "forest1200")  +  (6.323 * 
"shrub1200") +  (0.003445 * "patch1200") - (24.99 * "rough1200")) 


 
(Note:  The entire equation is exponentiated because the regression model is on the 
log scale.  You must back transform (i.e. exponentiate) the entire equation to get 
results in terms of bird abundance.) 
 


 
 


 Click OK to run the tool.  It will take approximately 5 minutes to finish. The results 
should look similar to the one below. 
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GIS Design II: Data Analysis and Model Building                                                                                    2012 
U.S. Fish and Wildlife Service                              National Conservation Training Center 


 


Fixed-Effects Regression                                                                                      11 


STEP 2: Reclassify the predictive map  
 


 Open the Reclassify tool (Spatial Analyst → Reclass).  Set the tool parameters to 
match the ones below. Run the tool.   
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 Symbolize the results to match the final BRWCA sage thrasher abundance map 
below. 


 


 
 
 





